杭電hdu 1711 Number Sequence【KMP模板】


講解博客:點擊打開鏈接

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29260    Accepted Submission(s): 12300


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1

#include <stdio.h>
#include <string.h>
int S[1000005],T[1000005];	//S是目標串,T是字串 
int next[2000000],l1,l2;
void Getnext()
{
	int i=0,j=-1;
	next[0]=-1;	j=next[i];
	while(i<l2)
	{
		if(j==-1||T[i]==T[j])
		{
			next[i+1]=j+1;
			i++; j++;
		}
		else
		{
			j=next[j];
		}
	}
}
int Kmp()
{
	Getnext();
	int i=0,j=0;
	while(i<l1)
	{
		if(j==-1 || S[i]==T[j])
		{
			i++; j++;	
			if(j == l2)
				return i-l2+1;
		}
		else
		{
			j=next[j];
		}
	} 
	return -1;
}
int main()
{
	int x;
	scanf("%d",&x);
	while( x--)
	{ 
		scanf("%d%d",&l1,&l2); 
		for(int i=0; i<l1; i++)
			scanf("%d",&S[i]);
		for(int i=0; i<l2; i++)
			scanf("%d",&T[i]);
		printf("%d\n", Kmp());
	} 
	return 0;
}











發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章