POJ 2349 Arctic Network(最小生成樹)

Arctic Network
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10091   Accepted: 3342

Description

The Department of National Defence (DND) wishes to connect several northern outposts by a wireless network. Two different communication technologies are to be used in establishing the network: every outpost will have a radio transceiver and some outposts will in addition have a satellite channel. 
Any two outposts with a satellite channel can communicate via the satellite, regardless of their location. Otherwise, two outposts can communicate by radio only if the distance between them does not exceed D, which depends of the power of the transceivers. Higher power yields higher D but costs more. Due to purchasing and maintenance considerations, the transceivers at the outposts must be identical; that is, the value of D is the same for every pair of outposts. 

Your job is to determine the minimum D required for the transceivers. There must be at least one communication path (direct or indirect) between every pair of outposts.

Input

The first line of input contains N, the number of test cases. The first line of each test case contains 1 <= S <= 100, the number of satellite channels, and S < P <= 500, the number of outposts. P lines follow, giving the (x,y) coordinates of each outpost in km (coordinates are integers between 0 and 10,000).

Output

For each case, output should consist of a single line giving the minimum D required to connect the network. Output should be specified to 2 decimal points.

Sample Input

1
2 4
0 100
0 300
0 600
150 750

Sample Output

212.13

Source



#include <stdio.h>
#include <math.h>
#include <algorithm>
#define MAX 505

using namespace std;

struct KK{
	int u;
	int v;
	double w;
}a[MAX*MAX/2];

struct PP{
	double x;
	double y;
}pp[MAX];
int father[MAX];

double d(double i,double j,double m,double n){
	return sqrt((m-i)*(m-i)+(n-j)*(n-j));
}

bool operator <(KK i,KK j){
	return i.w<j.w;
}

int findfather(int x){
	if(x!=father[x])
	return	father[x]=findfather(father[x]);
	return x;
}

int main()
{
	int n;
	scanf("%d",&n);
	while(n--){
		int s,p;
		scanf("%d%d",&s,&p);
		for(int i=1;i<=p;i++){
			scanf("%lf%lf",&pp[i].x,&pp[i].y);
		}
	//	for(int i=1;i<=p;i++)
		//	printf("%.2f %.2f \n",pp[i].x,pp[i].y);

		int t=1;
		for(int i=1;i<p;i++){
			for(int j=i+1;j<=p;j++){
				a[t].u=i;
				a[t].v=j;
				a[t].w=d(pp[i].x,pp[i].y,pp[j].x,pp[j].y);
				t++;
			//	printf("%.2f\n",a[t-1].w);
			}
		}
		sort(a+1,a+t);
		
	//	for(int i=1;i<=p*(p-1)/2;i++)
	//		printf("%d %d %.2lf\n",a[i].u,a[i].v,a[i].w);
		for(int i=1;i<=p;i++)
			father[i]=i;
		
		double result[MAX];
		int count=1;
		for(int i=1;i<t;i++){
			int x=findfather(a[i].u);
			int y=findfather(a[i].v);
			if(x!=y){
				result[count++]=a[i].w;
				father[x]=y;
			//	printf("%.2lf%d\n",result[i]);
			}
		}
		printf("%.2lf\n",result[p-s]);
				
	}
	
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章