POJ 2342 Anniversary party

http://poj.org/problem?id=2342


Anniversary party
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3451   Accepted: 1923

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form: 
L K 
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line 
0 0 

Output

Output should contain the maximal sum of guests' ratings.

Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0

Sample Output

5

Source



#include"stdio.h"
#include"stdlib.h"
#define   N  6002
#define MAX(a,b) ((a)>(b)? (a):(b))
typedef struct Employee 
{
    int  rank;
    struct Employee *lchild, *nextsibling;
    struct Employee *rightmost; //指向最右孩子節點
    int    id;
}Employee,*Epointer;

Epointer ptrEmployees[N];
int     dp[N][2];

//銷燬樹,釋放空間,防止內存泄露
void freeSpace(int n)
{
   int i;
   for(i=1 ; i<=n; ++i)
   {
       free(ptrEmployees[i]);
   }

}

void clear(int f[],int n)
{
    int i;
    for(i=1 ; i<=n; i++)
    {
        f[i] = 0;
    }
}
void dfs(int parent)
{
    Epointer pparent=ptrEmployees[parent];
    Epointer pchild;
    int child;
    if(pparent->lchild==NULL)
        return ;
    pchild = pparent->lchild;
    while(pchild->nextsibling)
    {
        child = pchild->id;
        dfs(child);
        dp[parent][1] += dp[child][0];
        dp[parent][0] += MAX(dp[child][0],dp[child][1]);
        pchild = pchild->nextsibling;
    }

    child = pchild->id;
    dfs(child);
    dp[parent][1] += dp[child][0];
    dp[parent][0] += MAX(dp[child][0],dp[child][1]);
}




int main()
{
    int n,i,child,parent;
    int f[N]={0};
    while(scanf("%d",&n)!=EOF)
    {
          
          for(i=1 ; i<=n; ++i)
          {
              scanf("%d",&dp[i][1]);
              dp[i][0]=0;
              ptrEmployees[i]=(Epointer)malloc(sizeof(Employee));
              ptrEmployees[i]->lchild = NULL;
              ptrEmployees[i]->nextsibling = NULL;
              ptrEmployees[i]->rank = dp[i][1];
              ptrEmployees[i]->id = i;
          }

          scanf("%d%d",&child,&parent);
          while(child+parent)         //child和parent均爲0時輸入結束
          {
              if( !ptrEmployees[parent]->lchild )
              {
                  ptrEmployees[parent]->lchild = ptrEmployees[child];
                  ptrEmployees[parent]->rightmost = ptrEmployees[child];
              }
              else
              {
                  ptrEmployees[parent]->rightmost->nextsibling = ptrEmployees[child];
                  ptrEmployees[parent]->rightmost = ptrEmployees[child];
              }
              f[child] = 1;   //child僱員有雙親
              scanf("%d%d",&child,&parent);
              
          }

          //find  president
          for(i=1 ; i<=n; ++i)
          {
              if(f[i]==0)
              {
                  dfs(i);
                  break;
              }
          }

          printf("%d\n",MAX(dp[i][0],dp[i][1]));
          freeSpace(n);
          clear(f,n);
    }
          
    return 0;

}

yinjili 2342 Accepted 628K 141MS C++ 2629B 2013-08-12 00:14:45

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章