POJ 1663 Number Steps

http://poj.org/problem?id=1663


Number Steps
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12812   Accepted: 6830

Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, ... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued. 

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

Source


#include"stdio.h"
int main()
{
	int N,x,y;
	scanf("%d",&N);
	while(N--)
	{
		scanf("%d%d",&x,&y);
		if(x<0 || y<0)
			printf("No Number\n");
		else if(x==y||x==y+2)
			printf("%d\n",x%2? (x+y-1):(x+y) );
		else
			printf("No Number\n");
	}


	return 0;
}



1663 Accepted 164K 16MS C++ 272B 2013-07-14 14:57:28


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章