hdu - problem 1671 Phone List【字典樹】

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18382    Accepted Submission(s): 6189


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
NO YES
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1075 1247 1800 1677 1298 

推薦一個字典樹入門的博客

#include <map>
#include <set>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#include <iostream>
#include <stack>
#include <cmath>
#include <string>
#include <vector>
#include <cstdlib>
//#include <bits/stdc++.h>
//#define LOACL
#define MAX 30
#define space " "
using namespace std;
//typedef long long LL;
typedef __int64 Int;
typedef pair<int, int> paii;
const int INF = 0x3f3f3f3f;
const double ESP = 1e-5;
const double PI = acos(-1.0);
const int MAXN = 1000000 + 10;
char str[30];
bool flag;
struct Trie {
    Trie *next[MAX];
    int endd;
};
Trie *root;
void create_trie(char str[]) {
    int len = strlen(str);
    Trie *p = root, *q;
    for(int i = 0; i < len; i++) {
        int id = str[i] - '0';
        if(p->next[id] == NULL) {
            q = new Trie;
            q->endd = 0;
            for(int j = 0; j < MAX; j++) {
				q->next[j] = NULL;
            }
            p->next[id] = q;
        }
        else {
			if(p->next[id]->endd == 1 || str[i + 1] == '\0') {
                flag = false; return;
            }
        }
        p = p->next[id];
    }
    p->endd = 1;
}
void free_trie(Trie* T) {
    for(int i = 0; i < 10; i++) {
        if(T->next[i] != NULL)
            free_trie(T->next[i]);
    }
    free(T);
}
int main() {
    int T, n;
    scanf("%d", &T);
    while(T--) {
        scanf("%d", &n);
        flag = true;
        root = new Trie;
        for(int i = 0;i < 10; i++) {
           root->next[i] = NULL;
           root->endd = 0;
        }
        for(int i = 0; i < n; i++) {
            scanf("%s", str);
            if(flag) create_trie(str);
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
        free_trie(root);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章