UVA1583 - Digit Generator(生成元)

For a positive integer N, the digit-sum of N is defined as the sum of N itself and its digits. When M
is the digitsum of N, we call N a generator of M.
For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of
256.
Not surprisingly, some numbers do not have any generators and some numbers have more than one
generator. For example, the generators of 216 are 198 and 207.
You are to write a program to find the smallest generator of the given integer.
Input
Your program is to read from standard input. The input consists of T test cases. The number of test
cases T is given in the first line of the input. Each test case takes one line containing an integer N,
1 ≤ N ≤ 100, 000.
Output
Your program is to write to standard output. Print exactly one line for each test case. The line is to
contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print ‘0’.
Sample Input
3
216
121
2005
Sample Output
198
0
1979
中文大意:
如果x加上x的各個數字之和得到y,就說x是y的生成元。給出n(1<=n<=100000),求最小生成元。無解輸出0。例如,n=216,121,2005時的解分別爲198,0,1979。
如: 198 => 198+1+9+8 =216 ,1979=>1979+1+9+7+9=2005


#include<cstdio>
#include<iostream>
#include<cstring>
const int N = 100005;
int ans[N]={0};
int main(){
	int T,n;
	for(int m = 1; m < N; m++){
		int x = m,y = m;
		while(x > 0){ // 1979+1+9+7+9=2005 拆分數然後相加
			y += x % 10;
			x /=10; 
		}
		if(ans[y] == 0 || m < ans[y])
		ans[y] = m;
	}
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n);
		printf("%d\n",ans[n]); 
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章