HDU 1015 Safecracker

 
Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST === 
"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution' if there is no correct combination. Use the exact format shown below."
 

Sample Input
1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END
 

Sample Output
LKEBA YOXUZ GHOST no solution
 

題意:要求在所給的一行字符串中找出按照要求的公式找出滿足結果的字符串,或許結果有多個,但是要求輸出字典序最大的那個字符串,所以需要排序。這道題目只能用深搜來做,寫的時候還是有些細節問題得注意,不然很容易出錯,若菜的我就是過了樣例後還是WA了好幾遍才交上。

看代碼

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
int target,in[20],ok,size;
char a[20],ans[5];
int f(char c,int x)
{
	int y=1,tp=c-'A'+1;
	for(int i=0;i<x;i++)
		y*=tp;
	return y;
}
bool judge()
{
	int temp=f(ans[0],1)-f(ans[1],2)+f(ans[2],3)-f(ans[3],4)+f(ans[4],5);
	if(temp==target)
		return true;
	return false;
}
bool cmp(char x,char y)
{
	return x>y;
}
void dfs(int n,int tot)
{
	if(tot==6)
	{
		if(judge())
			ok=1;
		return ;
	}
	if(n>=size)
		return ;

	if(in[n])   
	{
		dfs(n+1,tot);//第n個數已經用過找下一個
		return ;
	}
	ans[tot-1]=a[n];  //將第n個數放進數組中
	in[n]=1;

	dfs(0,tot+1);//從0開始進行判斷是否已經被用過
	if(ok)
		return ;
	in[n]=0;
	dfs(n+1,tot);
}
int main( )
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
	while(~scanf("%d %s",&target,a))
	{

		if(target==0&&strcmp(a,"END")==0)
			break;

		size=strlen(a);
		sort(a,a+size,cmp);

		ok=0;
		memset(in,0,sizeof(in));
		dfs(0,1);

		if(ok)
			printf("%s\n",ans);
		else
			puts("no solution");
	}
	return 0;
}


 


 

 

 

 


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章