【HDU3555】數位Dp1~n之間出現特徵數字個數

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 7279    Accepted Submission(s): 2541


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
3 1 50 500
 

Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

Author
fatboy_cw@WHU
 

Source


做的第一道數位DP啊!開始在找規律,搜索,做了很久終於找到了規律,上網一查發現原來這樣的叫數位DP。。

找到的規律就是這個樣子了。有了規律就很好做了。dp[i][0]=dp[i-1][0]*10-dp[i-1][1];是因爲要減去49XXX的情況。


題意就是找0到n有多少個數中含有49。數據範圍接近10^20

DP的狀態是2維的dp[len][3]
dp[len][0] 代表長度爲len不含49的方案數
dp[len][1] 代表長度爲len不含49但是以9開頭的數字的方案數
dp[len][2] 代表長度爲len含有49的方案數

狀態轉移如下
dp[i][0] = dp[i-1][0] * 10 - dp[i-1][1];  // not include 49  如果不含49且,在前面可以填上0-9 但是要減去dp[i-1][1] 因爲4會和9構成49
dp[i][1] = dp[i-1][0];  // not include 49 but starts with 9  這個直接在不含49的數上填個9就行了
dp[i][2] = dp[i-1][2] * 10 + dp[i-1][1]; // include 49  已經含有49的數可以填0-9,或者9開頭的填4

接着就是從高位開始統計

在統計到某一位的時候,加上 dp[i-1][2] * digit[i] 是顯然對的,因爲這一位可以填 0 - (digit[i]-1)
若這一位之前挨着49,那麼加上 dp[i-1][0] * digit[i] 也是顯然對的。
若這一位之前沒有挨着49,但是digit[i]比4大,那麼當這一位填4的時候,就得加上dp[i-1][1]


//Time:15MS	
//Memory:488K
#include<string.h>
#include<stdio.h>
long long dp[20][3];
int num[20];
int main()
{
    memset(dp,0,sizeof(dp));
    dp[0][0] = 1;
    for(int i = 1;i<= 20;i++){
        dp[i][0]=dp[i-1][0]*10-dp[i-1][1]; //dp[i][0] 表示i位數字中不含49的數字的個數
        dp[i][1]=dp[i-1][0];               //dp[i][1] 表示i位數字中以9開頭的數字的個數
        dp[i][2]=dp[i-1][2]*10+dp[i-1][1];//dp[i][2] 表示i位數字中含有49的數字的個數
    }
    int t;
    scanf("%d",&t);
    while(t--)
	{
        int len = 0,last = 0;
        long long ans = 0;
        long long n = 0;
        scanf("%I64d",&n);
        n++;
        memset(num,0,sizeof(num));
        while(n){
            num[++len]=n%10;
            n/=10;
        }
        bool flag=false;
        for(int i=len;i>=1;i--)
		{
            ans+=dp[i-1][2]*num[i];
            if(flag)
			{
                ans+=dp[i-1][0]*num[i];
            }
            if(!flag && num[i]>4)
			{
                ans+=dp[i-1][1];
            }
            if(last==4 && num[i]==9)
			{
                flag=true;
            }
            last=num[i];
        }
        printf("%I64d\n",ans);
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章