1037. Magic Coupon (25)

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
其实就是给了两个集合,每次从每个集合中各取出一个数做乘积后加和,最后求加和的最大结果,显然这个过程中必须正正相乘,负负相乘,否则结果不可能最大,因此索性把两个集合的正数负数全部分开,从大到小排序,依次做乘积即可。都是正数时,一定是大大组合的结果最大,如{1,2,3}和{4,5,6}两个集合,一定是3*6+2*5+1*4结果是最大的。。代码如下:
#include<iostream>
#include<vector>
#include<iterator>
#include<algorithm>

using namespace std;

bool cmp(int a, int b){
	return a > b;
}

int main(){
	vector<int> pos_a, pos_b, neg_a,neg_b;
	int m, n, temp;
	int ans = 0;//最终结果
	cin >> m;
	for (int i = 0; i < m; i++){
		cin >> temp;
		if (temp >= 0)
			pos_a.push_back(temp);
		else
			neg_a.push_back(-temp);
	}
	cin >> n;
	for (int i = 0; i < n; i++){
		cin >> temp;
		if (temp >= 0)
			pos_b.push_back(temp);
		else
			neg_b.push_back(-temp);
	}
	sort(pos_a.begin(), pos_a.end(), cmp);
	sort(pos_b.begin(), pos_b.end(), cmp);
	sort(neg_a.begin(), neg_a.end(), cmp);
	sort(neg_b.begin(), neg_b.end(), cmp);
	vector<int>::iterator a = pos_a.begin(), b = pos_b.begin();

	while (a != pos_a.end() && b != pos_b.end()){
		ans += *a * *b;
		a++; b++;
	}
	a = neg_a.begin(), b = neg_b.begin();
	while (a != neg_a.end() && b != neg_b.end()){
		ans += *a * *b;
		a++, b++;
	}
	cout << ans << endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章