1044. Shopping in Mars (25)

1044. Shopping in Mars (25)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
這道題實際上就是給出一個數的序列,從中找出一個序列,使其和大於等於m且最小。
類似動態規劃:每個點k都要記錄,以k爲序列尾,可能取到的最優解,即>=m且最小的序列,k+1點計算時,先取和k相同的起點,money【k+1】 = money【k】 + value【k+1】,然後再依次將起點向前+1以達到“最小”。

#include <cstdio>
#include <string.h>

using namespace std;
struct
{
	int start;
	int end;
	int money;
} point[100001];
int main(){
	int min = -1;
	int n,m;
	int value[100001];
	int record[100001], index = 0;
	scanf("%d%d",&n,&m);
	for(int i=1;i<=n;i++)
		scanf("%d",&value[i]);
	memset(point,0,sizeof(int)*3*100001);

	for(int i=1;i<=n;i++){
		if(i == 1){
			point[i].start = point[i].end = 1;
			point[i].money = value[i];
			if(point[i].money >= m){
				record[index++] = i;
				min = point[i].money;
			}
			continue;
		}
		point[i].end = i;
		point[i].start = point[i-1].start;
		point[i].money = point[i-1].money + value[i];
		while(point[i].money - value[point[i].start] >= m){
			point[i].money -= value[point[i].start];
			point[i].start ++;
		}
		if(point[i].money >= m && (point[i].money < min || min == -1)){
			min = point[i].money;
			index = 0;
			record[index++] = i;
		}
		else if(point[i].money >= m && point[i].money == min){
			record[index++] = i;
		}
	}

	for(int i=0;i<index;i++){
		int temp = record[i];
		printf("%d-%d\n",point[temp].start,point[temp].end);
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章