1019. General Palindromic Number (20)

原文地址:https://www.patest.cn/contests/pat-a-practise/1019

1019. General Palindromic Number (20)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two non-negative numbers N and b, where 0 <= N <= 109 is the decimal number and 2 <= b <= 109 is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line "Yes" if N is a palindromic number in base b, or "No" if not. Then in the next line, print N as the number in base b in the form "ak ak-1 ... a0". Notice that there must be no extra space at the end of output.

Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1

#include<iostream>
using namespace std;

int main(){
	int n, b;
	int bit[100];
	bool yes = true;
	cin >> n >> b;
	int count = -1;

	bit[0] = 0;

	for (;;){
		if (n > 0){
			count++;
			bit[count] = n % b;
			n /= b;
		}
		else
			break;
	}
	if (count == -1)//只有當n=0時會出現,此時應該有1位,爲0
		count = 0;

	for (int i = 0; i <= count; i++){
		if (bit[i] == bit[count - i])
			continue;
		else{
			yes = false;
			break;
		}
	}
	if (yes){
		cout << "Yes" << endl;
	}
	else{
		cout << "No" << endl;
	}

	for (int i = count; i >= 0; i--){
		cout << bit[i];
		if (i != 0)
			cout << " ";
	}
	cout << endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章