POJ - 1125 Stockbroker Grapevine (floyd+判斷從某一源點是否走完所有點)

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.
Input
Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

Output
For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.
Sample Input
3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0
Sample Output
3 2
3 10
題意:你的程序將輸入不同組股票經紀人的數據。每套都以一系列股票經紀人開始。接下來是每個股票經紀人的一條線,其中包含他們接觸的人數,這些人是誰,以及他們將信息傳遞給每個人的時間。每個股票經紀行的格式如下:行開始於聯繫人數量(n),隨後是n對整數,每個聯繫人一對。每一對首先列出一個指向聯繫人的號碼(例如,'1'表示集合中第一個人),然後是以分鐘爲單位向該人傳遞信息的時間。沒有特殊的標點符號或間隔規則。

每個人被編號1到股票經紀人的數量。傳遞消息的時間將在1到10分鐘(含)之間,聯繫人的數量將介於0到1之間,小於股票經紀人的數量。股票經紀人的數量將在1到100之間。投資由一組包含0(零)人的股票經紀人終止。

解析:數據不算太大,直接用Floyd求出最短距離。問題是,怎樣判斷從某一源點走完全程呢?這就需要維護一個最大值,即最長的就是走完全程(如果是INF呢,就需要特別處理一下,但這個題數據比較水,不存在不相通的情況)。

#include<stdio.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
int n,m;
int e[220][220];
void floyd()
{
    int i,j,k;
    for(k=1; k<=n; k++)
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
                if(e[i][j]>e[i][k]+e[k][j])
                    e[i][j]=e[i][k]+e[k][j];
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
            if(i==j)e[i][j]=0;
           else e[i][j]=inf;
           int v,w;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&m);
            for(int j=1;j<=m;j++)
            {
                scanf("%d%d",&v,&w);
                e[i][v]=w;
            }
        }
        floyd();
        int minn;
        int ans=inf;
        int f=1,k;
        for(int i=1;i<=n;i++)
        {
            minn=-1;          //找從某一出發用時最長的,就是走完了所有點
            for(int j=1;j<=n;j++)
            {
                if(i==j)continue;
                minn=max(e[i][j],minn);
            }
            if(ans>minn)      //找符合題意的最小值
            {
                f=0;
                ans=minn;
                k=i;
            }
        }
        if(f==0)printf("%d %d\n",k,ans);
        else printf("disjoint\n"); //可以不寫
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章