最短路 floyd變形 POJ-2253

題目:

Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 51723   Accepted: 16420

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

題意:給定n個點,任意兩點都完全連通。求第一個點到第二個點的所有通路中最長的那個通路里的最小的邊。

方法:floyd變形。求最長路中的最短邊。將G數組定義爲存儲i到j最長路的最短邊。改變floyd中的鬆弛條件即可。

WA點:%.3lf用c++交!!!用G++會無限WA。。。TnT

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<stack>
// #define Reast1nPeace

typedef long long ll;

using namespace std;

const int MAXN = 210;

int c;

struct node{
	double x,y;
}Point[MAXN];

double dis(node a , node b){
	double i = a.x - b.x;
	double j = a.y - b.y;
	return sqrt(i*i + j*j);
}

double G[MAXN][MAXN];

void floyd(){
	for(int k = 1 ; k<=c ; k++){
		for(int i = 1 ; i<=c-1 ; i++){
			for(int j = i+1 ; j<=c ; j++){
				if(G[i][j]>G[i][k] && G[i][j]>G[k][j] ){ //i到k的最短邊,k到i的最短邊都要小於原來的i到j的最短邊,
					//三角形兩邊之和大於第三邊既保證了新的i到j的距離比原來長,又保證了 i到k的最短邊,k到i的最短邊其一爲新的i到j的最短邊 
					
					if(G[i][k] < G[k][j]){  //爲了保證i到k到j連通,新的最短邊應該選擇二者中長的那個 
						G[i][j] = G[j][i] =  G[k][j];
					}
					else{
						G[i][j] = G[j][i] =  G[i][k];
					}
				}
			}
		}
	}
}

int main(){
#ifdef Reast1nPeace
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
#endif
  int cases = 1;
	
	while(scanf("%d",&c)!=EOF && c){
		for(int i = 1 ; i<=c ; i++){
			scanf("%lf%lf",&Point[i].x,&Point[i].y);
		}
	
		for(int i = 1 ; i<=c-1 ; i++){
			for(int j = i+1 ; j<=c ; j++){
				G[i][j] = G[j][i] = dis(Point[i],Point[j]);
			}
		}
		
		floyd();
		
		printf("Scenario #%d\n",cases++);
		printf("Frog Distance = %.3lf\n\n",G[1][2]);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章