csu1783——聊天止于呵呵(字符串)

Description
(现代版)俗话说:流言止于智者,聊天止于呵呵。输入一段聊天记录,你的任务是数一数有

多少段对话“止于呵呵”,即对话的最后一句话包含单词 hehe 或者它的变形。

具体来说,我们首先提取出对话的最后一句话,把所有非字母的字符替换成空格,把所有字符 替换成小写,然后导出一个单词列表(由空格隔开),只要列表中的任何一个单词是 hehe,这 段对话就算作“止于呵呵”。比如,”Hi! Are you OK?” 会变成四个单词:hi, are, you, ok。注 意,单词列表可以是空的(比如,这句话是:”?!?!!”)

有些人喜欢使用 hehe 的变形,这些变形也应被视为“呵呵”。为了简单起见,本题只考虑由 n(n>1)个 he 连接而成的单词,比如 hehehe 或者 hehehehe。注意,以 hehe 为连续子串的其他单 词不应视为“呵呵”,比如 hehee,或者 ehehe。

每两个不同人之间的所有对话算作“一段对话”。
Input
输入仅包含一组数据,每行是一句对话,格式为:
人名1->人名2: 一句话.
每行最多包含 1000 个字符,最多 100 行。

Output
输出“止于呵呵”的对话段落所占的百分比,四舍五入到最近的整数。输入数据保证答案不会
同时和两个整数最近。

Sample Input
A->B: Hello!
A->C: Hi!
B->A: Hehe
B->D: Hei!
D->B: How are you?
A->C: Hi???
A->C: Are you there?
B->D: Hehehei!
D->B: What does hehehei mean?
F->E: I want to hehehehehe yah.
Sample Output
50%
Hint
样例解释
A 和 B 之间的最后一句话是”Hehe”.
A 和 C 之间的最后一句话是”Are you there?”.
B 和 D 之间的最后一句话是”What does hehehei mean?”.
E 和 F 之间的最后一句话是”I want to hehehehehe yah”. 最后第一段和最后一段话是“止于呵呵”的(注意最后一段对话是以呵呵的变种结束),因此 比例是 50%

可以确定的是hehe及其变种一定只存在对话的最后一句,所以只要分析有多少段对话,再把hehe出现的次数与之相除就行了

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <cctype>
#define INF 0x3f3f3f3f
#define MAXN 10000005
#define Mod 1000000007
using namespace std;
set<pair<string,string> > table;
bool check(string s)
{
    if(s.length()<4)
        return false;
    string tmp="he",s1="";
    int len=s.length()/2;
    for(int i=1; i<=len; ++i)
        s1+=tmp;
    if(s1==s)
        return true;
    else
        return false;
}
int main()
{
    string s;
    double ans=0;
    table.clear();
    while(getline(cin,s))
    {
        s+='#';
        string name1="",name2="";
        int i=0,len=s.length();
        while(s[i]!='-')
        {
            name1+=s[i];
            i++;
        }
        i+=2;
        while(s[i]!=':')
        {
            name2+=s[i];
            i++;
        }
        if(name1<name2)
            swap(name1,name2);
        if(table.find(make_pair(name1,name2))==table.end())
            table.insert(make_pair(name1,name2));
        i+=2;
        string word="";
        for(; i<len; ++i)
        {
            if((s[i]>='A'&&s[i]<='Z')||(s[i]>='a'&&s[i]<='z'))
                word+=tolower(s[i]);
            else
            {
                if(check(word))
                {
                    ans++;
                    break;
                }
                word="";
            }
        }
    }
    ans=ans/table.size();
    ans*=100;
    printf("%d%%\n",int(ans));
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章