HDOJ 1217 Arbitrage 【Floyd 有負權】

Arbitrage

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5804    Accepted Submission(s): 2691


Problem Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 

Sample Input
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 
Sample Output
Case 1: Yes Case 2: No
題目鏈接:HDOJ 1217 Arbitrage 【Floyd 有負權】

       貨幣A 可以購買 X 貨幣B ,問能否通過一種路徑,用X貨幣能買到比本身更多的貨幣。
並沒有說兩種貨幣可以互相換,可以用Floyd算法變式,將加法換爲乘法,
不能交換的兩種貨幣的權值設置爲0,只要有一種貨幣與自己的最短路徑大於1就表明能買到比本身更多的貨幣.

用map映射,將字符串轉換爲整型編號

已AC代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;

map<string,int> coin;//字符串對整型的映射 
double dist[100][100],val;
int n,m;
char str[100],ch1[100],ch2[100];
void Floyd()
{
	int i,j,k;
	for(k=1;k<=n;++k)
	{
		for(i=1;i<=n;++i)
		{
			for(j=1;j<=n;++j)
			{
				if(dist[i][j]<dist[i][k]*dist[k][j])//加變乘 
					dist[i][j]=dist[i][k]*dist[k][j];
			}
		}
	}
}
int main()
{
	int i,j,cnt,CASE=1;
	while(scanf("%d",&n),n)
	{
		cnt=1;
		for(i=0;i<n;++i)
		{
			scanf("%s",str);
			coin[str]=cnt++;
		}
		memset(dist,0,sizeof(dist));
		scanf("%d",&m);
		while(m--)
		{
			scanf("%s%lf%s",ch1,&val,ch2);
			dist[coin[ch1]][coin[ch2]]=val;
		}
		Floyd();
		int flag=0;
		for(i=1;i<=n;++i)
		{
			if(dist[i][i]>1)
			{
				flag=1;
				break;
			}
		}
		if(flag==1)
			printf("Case %d: Yes\n",CASE++);
		else
			printf("Case %d: No\n",CASE++);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章