UVA - 208 Firetruck


 Firetruck 

The Center City fire department collaborates with the transportation department to maintain maps of the city which reflects the current status of the city streets. On any given day, several streets are closed for repairs or construction. Firefighters need to be able to select routes from the firestations to fires that do not use closed streets.

Central City is divided into non-overlapping fire districts, each containing a single firestation. When a fire is reported, a central dispatcher alerts the firestation of the district where the fire is located and gives a list of possible routes from the firestation to the fire. You must write a program that the central dispatcher can use to generate routes from the district firestations to the fires.

Input

The city has a separate map for each fire district. Streetcorners of each map are identified by positive integers less than 21, with the firestation always on corner #1. The input file contains several test cases representing different fires in different districts.

  • The first line of a test case consists of a single integer which is the number of the streetcorner closest to the fire.
  • The next several lines consist of pairs of positive integers separated by blanks which are the adjacent streetcorners of open streets. (For example, if the pair 4 7 is on a line in the file, then the street between streetcorners 4 and 7 is open. There are no other streetcorners between 4 and 7 on that section of the street.)
  • The final line of each test case consists of a pair of 0's.

Output

For each test case, your output must identify the case by number (CASE #1CASE #2, etc). It must list each route on a separate line, with the streetcorners written in the order in which they appear on the route. And it must give the total number routes from firestation to the fire. Include only routes which do not pass through any streetcorner more than once. (For obvious reasons, the fire department doesn't want its trucks driving around in circles.)

Output from separate cases must appear on separate lines.

The following sample input and corresponding correct output represents two test cases.

Sample Input

6
1 2
1 3
3 4
3 5
4 6
5 6
2 3
2 4
0 0
4
2 3
3 4
5 1
1 6
7 8
8 9
2 5
5 7
3 1
1 8
4 6
6 9
0 0

Sample Output

CASE 1:
1 2 3 4 6
1 2 3 5 6
1 2 4 3 5 6
1 2 4 6
1 3 2 4 6
1 3 4 6
1 3 5 6
There are 7 routes from the firestation to streetcorner 6.
CASE 2:
1 3 2 5 7 8 9 6 4
1 3 4
1 5 2 3 4
1 5 7 8 9 6 4
1 6 4
1 6 9 8 7 5 2 3 4
1 8 7 5 2 3 4
1 8 9 6 4

There are 8 routes from the firestation to streetcorner 4.

題意:

找出到給出數據的所有的路線;

之前從頭搜索到尾,結果超時,後來將可以到達終點的數據儲存起來;

然後再在該數組中回溯,就不會超時;

#include <iostream>
#include <cstdio>
#include <queue>
#include <algorithm>
#include <cstring>
#define N 100
using namespace std;

int u, v;
int a[N][N];
int n, kase = 0;
int sum,cou;
int num[N],vis[N],c[N];

void bfs() { //爲了找出能夠到達n的所以的點,儲存在一個數組中,直接搜索會超時
	queue<int> q;
	q.push(n);
	vis[n] = 1;
	num[sum++] = n;
	while (!q.empty()) {
		int f = q.front();
		q.pop();
		for (int i = 1; i < 25; i++) {
			if (!vis[i] && a[f][i])	{
				vis[i] = 1;
				num[sum++] = i;
				q.push(i);
			}
		}
	}
}

void dfs(int cur, int e) { // 點數, 終點
	if (e == n) {
		for (int i = 0; i < cur-1; i++)
			printf("%d ",c[i]);
		printf("%d\n",c[cur-1]);	
		cou++;
	}
	else {
		for (int i = 0; i < sum; i++) {
			if (!vis[num[i]] && a[e][num[i]]) {
				vis[num[i]] = 1;
				c[cur] = num[i];
				dfs(cur+1,num[i]);
				vis[num[i]] = 0;
			}
		}	
	}	
}

int main () {
	while (scanf("%d",&n) != EOF) {
		if (n == 0) break; 
		printf("CASE %d:\n",++kase);
		sum = 0; 
		cou = 0;
		memset(vis,0,sizeof(vis));
		memset(num,0,sizeof(num));
		memset(a,0,sizeof(a));
		while (scanf("%d%d",&u,&v) != EOF){
			if (u == 0 && v == 0) break;
			a[u][v] = 1;
			a[v][u] = 1;	
		}

		bfs();
//		printf("%d\n",sum);
		memset(vis,0,sizeof(vis)); //記得再一次清零
		sort(num,num+sum);
		vis[1] = 1; c[0] = 1;
		dfs(1,1);
		printf("There are %d routes from the firestation to streetcorner %d.\n",cou,n);	
	}

	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章