【hdu 2548】 A strange lift (Dijlstra )

A strange lift

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 12   Accepted Submission(s) : 7
Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?
 

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
5 1 5 3 3 1 2 5 0
 

Sample Output
3
 
注意一下樓梯的方向是單向的就行了
#include<iostream>
#include<cstring>
#include<cstdio>
#define INF 0x7ffffff
#define MAX 205
using namespace std;
int map[MAX][MAX];
int visit[MAX],dis[MAX];
int N,A,B;
void Dijkstra(int s,int n)
{
     int i,j;
     for(i=1;i<=n;i++)  dis[i]=map[s][i],visit[i]=false;
     dis[s]=0;//important
     visit[s]=true;// important
     for(i=1;i<=n;i++)
     {
            int k,tmp=INF;
            for(j=1;j<=n;j++)
                  if(!visit[j]&&dis[j]<tmp) tmp=dis[k=j];
            if(tmp==INF) break; //important
            visit[k]=true; 
            for(j=1;j<=n;j++)
               if(!visit[j]&&dis[j]>dis[k]+map[k][j])
                  dis[j]=dis[k]+map[k][j];         
     }
}


int main()
{
    int i,j,k;
    while(scanf("%d",&N),N)
    {
         scanf("%d%d",&A,&B);
        // memset(map,INF,sizeof(map));
         for(i=1;i<=N;i++)
            for(j=1;j<=N;j++)
               map[i][j]=INF;
         for(i=1;i<=N;i++)
         {
            scanf("%d",&k);
            if(i-k>=1) map[i][i-k]=1;
            if(i+k<=N) map[i][i+k]=1;
         }
         Dijkstra(A,N);
         if(dis[B]==INF) printf("-1\n");
         else printf("%d\n",dis[B]);
    }
    return 0;
}







發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章