【hdu】 Nightmare

Nightmare

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 4
Problem Description
Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
4 -1 13
 
這道題真是把人搞傷了,關鍵在於並不是根據它有沒有被訪問過而放不放入隊列(visit數組),而是在於當前tt.t<mark[tt.x][tt.y],mark比tt.t後更新
// www.cpp : 定義控制檯應用程序的入口點。
//

#include "stdafx.h"


#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
#define MEM(arr,w) memset(arr,w,sizeof(arr))
#define MAX 10
using namespace std;
struct node
{
	int x,y,t,sum;//t已用時間,sum實際走過多少步
}st,ed,ss,tt;
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int map[MAX][MAX],mark[MAX][MAX];
int n,m,mint;
bool Judge(node s)
{
	if(s.x>=0&&s.x<n&&s.y>=0&&s.y<m&&map[s.x][s.y]!=0)return 1;
	return 0;
}
void Init()
{
	MEM(mark,INF);
	mint=INF;
}
void BFS()
{ //0牆壁,1大路,2起始點,3出口,4復位炸彈 
	queue<node> Q;
	Q.push(st);
	mark[st.x][st.y]=0;
	while(!Q.empty())
	{
		ss=Q.front();
		Q.pop();
		if(map[ss.x][ss.y]==4&&ss.t<6) {ss.t=0;mark[ss.x][ss.y]=0;}//關鍵!
		if(ss.x==ed.x&&ss.y==ed.y) if(ss.t<=5&&mint>ss.sum) mint=ss.sum;
		for(int i=0;i<4;i++)
		{
			tt.x=ss.x+dir[i][0];
			tt.y=ss.y+dir[i][1];
			tt.t=ss.t+1;
			tt.sum=ss.sum+1;
			if(Judge(tt))
			{			
				if(tt.t<mark[tt.x][tt.y]) 
				{
					mark[tt.x][tt.y]=tt.t;
					Q.push(tt);
				}

			}
		}
	}	
}
int main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==2) st.x=i,st.y=j,st.t=0,st.sum=0;
				if(map[i][j]==3) ed.x=i,ed.y=j;
			}
			Init();
			BFS();
			if(mint!=INF) printf("%d\n",mint);
			else puts("-1");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章