HDOJ 5339 Untitled

Untitled

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1329    Accepted Submission(s): 783


Problem Description
There is an integer a and n integers b1,,bn. After selecting some numbers from b1,,bn in any order, say c1,,cr, we want to make sure that a mod c1 mod c2 mod mod cr=0 (i.e., a will become the remainder divided by ci each time, and at the end, we want a to become 0). Please determine the minimum value of r. If the goal cannot be achieved, print 1 instead.
 

Input
The first line contains one integer T5, which represents the number of testcases. 

For each testcase, there are two lines:

1. The first line contains two integers n and a (1n20,1a106).

2. The second line contains n integers b1,,bn (1in,1bi106).
 

Output
Print T answers in T lines.
 

Sample Input
2 2 9 2 7 2 9 6 7
 

Sample Output
2 -1
 


題意:給你20個數和a,a對這20個數進行取模,問最少需要多少個數使得取模爲0。
因爲只有20個數,那麼我直接暴力DFS就行,這裏有一個細節,如果a<b,那麼a%b=a,也就是說小數對大數取模,答案還是小數,也就相當於沒有取模但是多用了一個數,那麼我們就排除掉這種情況,使得每次取模都是有意義的,就能過了;

#include<stdio.h>
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
int a,flag;
int n;
int b[30];
int use[30];
void dfs(int sum,int m)
{
    if(flag==1)
        return;
    if(sum<0)
        return;
    if(sum==0&&m==0)
        flag=1;
    for(int i=1;i<=n;i++)
    {
        if(use[i]==0&&b[i]<=m)
        {
            use[i]=1;
            dfs(sum-1,m%b[i]);
            use[i]=0;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&a);

        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        int ans=-1;
        for(int i=1;i<=n;i++)
        {
            memset(use,0,sizeof(use));
            flag=0;
            dfs(i,a);
            if(flag==1)
            {
                ans=i;
                break;
            }
        }
        printf("%d\n",ans);
    }
return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章