cable master

Cable master
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 46685   Accepted: 9955

Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.

Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.

Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).

Sample Input

4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

Source

個人理解:二分法枚舉所有可能出現的長度,將該長度分成多於或等於若干份,從中選取最大長度,裏面運用了c++算法,從而得到該長度,還有注意對精度的設定,以及c++中一些頭文件的使用。

結果 語言 時間 內存
Accepted c++ 94Ms 272K

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn=10000+10;
int n,m;
int a[maxn],maxa;
void solve()
{
    int L=0,R=maxa+1,mid;
    int ans=0;
    while(L+1<R){
        ans=0;
        mid=(L+R)/2;
        for(int i=0;i<n;i++)
            ans+=a[i]/mid;
        if(ans<m)R=mid;
        else L=mid;
    }
    printf("%.2lf\n",L/100.00);
}
int main()
{
    cin>>n>>m;
    maxa=0;
    double t;
    for(int i=0;i<n;i++){
        scanf("%lf",&t);
        a[i]=t*100;
        maxa=max(maxa,a[i]);
    }
    solve();
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章