POJ - 3660 Cow Contest

Cow Contest
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 12848
Accepted: 7149

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ AN; 1 ≤ BN; AB), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

Source

[Submit]   [Go Back]   [Status]   [Discuss]



題意:

牛在比賽,問知道兩頭牛的關係。最終可以確定多少個牛的名次


思路:

只要找到某隻牛與其他所有牛的關係則其名次一定可以確定


代碼:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm> 
using namespace std;
#define INF 0x3f3f3f3f

int dis[105][105];
int n,m;

void floyd()
{
	for(int k=1;k<=n;k++)
		for(int i=1;i<=n;i++)
			for(int j=1;j<=n;j++)
			//i 可直接或間接打敗 j 
				if(dis[i][j] || (dis[i][k]&&dis[k][j]))
					dis[i][j]=1;
}

int main()
{
	scanf("%d%d",&n,&m);
	
	memset(dis,0,sizeof(dis));
	for(int i=0;i<m;i++)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		dis[a][b]=1;//不能雙向 
	}
	
	floyd();
	
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		int t=0;
		for(int j=1;j<=n;j++)
		{
			if(dis[i][j] || dis[j][i])t++;
		}
		//只要確定了自己和其他所有的關係,則名次一定確定 
		if(t==n-1)sum++;
	}
	printf("%d\n",sum);
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章