hdu 5115 Dire Wolf(區間DP)

Dire Wolf

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 353    Accepted Submission(s): 210


Problem Description
Dire wolves, also known as Dark wolves, are extraordinarily large and powerful wolves. Many, if not all, Dire Wolves appear to originate from Draenor.
Dire wolves look like normal wolves, but these creatures are of nearly twice the size. These powerful beasts, 8 - 9 feet long and weighing 600 - 800 pounds, are the most well-known orc mounts. As tall as a man, these great wolves have long tusked jaws that look like they could snap an iron bar. They have burning red eyes. Dire wolves are mottled gray or black in color. Dire wolves thrive in the northern regions of Kalimdor and in Mulgore.
Dire wolves are efficient pack hunters that kill anything they catch. They prefer to attack in packs, surrounding and flanking a foe when they can.
— Wowpedia, Your wiki guide to the World of Warcra

Matt, an adventurer from the Eastern Kingdoms, meets a pack of dire wolves. There are N wolves standing in a row (numbered with 1 to N from left to right). Matt has to defeat all of them to survive.

Once Matt defeats a dire wolf, he will take some damage which is equal to the wolf’s current attack. As gregarious beasts, each dire wolf i can increase its adjacent wolves’ attack by bi. Thus, each dire wolf i’s current attack consists of two parts, its basic attack ai and the extra attack provided by the current adjacent wolves. The increase of attack is temporary. Once a wolf is defeated, its adjacent wolves will no longer get extra attack from it. However, these two wolves (if exist) will become adjacent to each other now.

For example, suppose there are 3 dire wolves standing in a row, whose basic attacks ai are (3, 5, 7), respectively. The extra attacks bi they can provide are (8, 2, 0). Thus, the current attacks of them are (5, 13, 9). If Matt defeats the second wolf first, he will get 13 points of damage and the alive wolves’ current attacks become (3, 15).

As an alert and resourceful adventurer, Matt can decide the order of the dire wolves he defeats. Therefore, he wants to know the least damage he has to take to defeat all the wolves.
 

Input
The first line contains only one integer T , which indicates the number of test cases. For each test case, the first line contains only one integer N (2 ≤ N ≤ 200).

The second line contains N integers ai (0 ≤ ai ≤ 100000), denoting the basic attack of each dire wolf.

The third line contains N integers bi (0 ≤ bi ≤ 50000), denoting the extra attack each dire wolf can provide.
 

Output
For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), y is the least damage Matt needs to take.
 

Sample Input
2 3 3 5 7 8 2 0 10 1 3 5 7 9 2 4 6 8 10 9 4 1 2 1 2 1 4 5 1
 

Sample Output
Case #1: 17 Case #2: 74
Hint
In the first sample, Matt defeats the dire wolves from left to right. He takes 5 + 5 + 7 = 17 points of damage which is the least damage he has to take.
 


題意:有n只狼,每隻狼有兩種屬性,一種攻擊力一種附加值,每殺一隻狼,受到的傷害值爲
這隻狼的攻擊值與它旁邊的兩隻狼的附加值的和,求把所有狼都殺光受到的最小的傷害值。.

思路:dp[i][j]表示把區間i,j內的所有狼殺光所受到的最小的傷害。
狀態轉移方程爲:

dp[i][j]=min{dp[i][k-1]+dp[k+1][j]+a[k]+b[i-1]+b[j+1]}(i<=k<j);

其中a[i]爲第i只狼的攻擊力,b[i]爲第i只狼的附加值。

狀態方程中枚舉的k,表示區間i,j內最後殺死的狼的編號。


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define ll long long
using namespace std;
const int inf=999999999;
const int maxn=210;

struct node
{
    int val,add;
}a[maxn];
int n,dp[maxn][maxn];

void initial()
{
    memset(dp,-1,sizeof(dp));
}

void input()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)  scanf("%d",&a[i].val);
    for(int i=1;i<=n;i++)  scanf("%d",&a[i].add);
    a[0].val=a[0].add=0;
    a[n+1].val=a[n+1].add=0;
}

int DP(int l,int r)
{
    if(l>r)  return 0;
    if(dp[l][r]!=-1)  return dp[l][r];
    int ans=inf;
    for(int i=l;i<=r;i++)
        ans=min(ans,DP(l,i-1)+DP(i+1,r)+a[i].val+a[l-1].add+a[r+1].add);
    return dp[l][r]=ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    for(int co=1;co<=T;co++)
    {
        initial();
        input();
        printf("Case #%d: %d\n",co,DP(1,n));
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章