USACO 2008 Open Silver-roads around the farm(水題)

Description

Farmer John's cows have taken an interest in exploring the territory around the farm. Initially, all N (1 ≤ N ≤ 1,000,000,000) cows commence traveling down a road in one big group. Upon encountering a fork in the road, the group sometimes chooses to break into two smaller (nonempty) groups with each group continuing down one of the roads.  When one of those groups arrives at another fork, it might split again, and so on.

The cows have crafted a peculiar way of splitting: if they can split into two groups such that the sizes of the groups differ by exactly K (1 ≤ K ≤ 1000), then they will split in that way; otherwise, they stop exploring and just start grazing peacefully.

Assuming that there will always be new forks in the road, compute the final number of groups of peacefully grazing cows.

Input

* Line 1: Two space-separated integers: N and K

Output

* Line 1: A single integer representing the number of groups of grazing cows

Sample Input

6 2

Sample Output

3

Hint

SAMPLE INPUT DETAILS:

There are 6 cows and the difference in group sizes is 2.

SAMPLE OUTPUT DETAILS:

There are 3 final groups (with 2, 1, and 3 cows in them).

6
/ \
2   4
    / \
    1   3

 

慢慢領會吧,令人厭的遞歸。。。

#include <stdio.h>
int n,k;
int f(int n)
{
    if((n+k)%2||n<=k) return 1;
    int x;
    return f(x=(n+k)/2)+f(n-x);
}
int main()
{
  //int n,k;
  while(~scanf("%d%d",&n,&k))
  {
    printf("%d\n",f(n));
  }
  return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章