A1015 Reversible Primes (20分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

Solution: 

#include <bits/stdc++.h>
using namespace std;

bool isprime(int n) {
	if (n < 2) return false;
	if (n == 2) return true;
	for (int i = 2; i <= sqrt(n); i++) {
		if (n % i == 0) {
			return false;
		}
	}
	return true;
}
int main() {
	int s, r;
	while (true) {
		cin >> s;
		if (s <= 0) break;
		cin >> r;
		if (!isprime(s)) {
			cout << "No" << endl;
			continue;
		} else {
			deque<int> Q;
			while (s != 0) {
				Q.push_back(s % r);
				s /= r;
			}
			while (!Q.empty()) {
				s = s*r + Q.front();
				Q.pop_front();
			}
			if (isprime(s)) {
				cout << "Yes" << endl;
			} else {
				cout << "No" << endl;
			}
		}	
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章