Catch That Cow

 

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
 
 

大體題意:John 去抓奶牛,題目給出Joh和奶牛的座標,求John抓住奶牛的最短時間。其中john可以前進,後退,傳送。使用寬搜解這個題,最先找到的結果就是最短時間。

 

先算+1, 再-1,最後*2.注意搜索時的上下限。

 代碼:

 

//Catch That Cow
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>


using namespace std;


const int MAXN = 2000000;
//int n, m;
typedef pair<int, int> P;
int n,m;
bool num[MAXN];
queue<P> que;


int bfs(int x,int y,int ans)
{
    if(y - x <= 0) return ans = x - y;
    while(!que.empty()) que.pop();
    que.push(P(x,ans));
    while(!que.empty())
    {
        P p = que.front();
        que.pop();
        if(p.first == y) return p.second;
        if(p.first + 1 >= 0&&p.first + 1 <= 100000 && !num[p.first+1])
        {
            num[p.first+1] = true;
            que.push(P(p.first + 1, p.second + 1));
        }
        if(p.first >= 0&&p.first - 1 <= 100000 && !num[p.first-1])
        {
            num[p.first-1] = true;
            que.push(P(p.first - 1, p.second + 1));
        }
        if(p.first * 2 >= 0&&p.first * 2  <= 100000 && !num[p.first*2])
        {
            num[p.first*2] = true;
            que.push(P(p.first * 2, p.second + 1));
        }


    }
    return 0;
}


int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        memset(num,false,sizeof(num));
        printf("%d\n",bfs(n,m,0));
    }
    return 0;
}

 

 

 

 

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章