HDU 1829 A bug's life

 

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
 
 

 

廢話不說上主題

解題思路:

1.這個題用並查集;

2.這個題有個坑點,回車坑;

3.給par數組開兩個種類(加上個轉移量),利用same比較每次輸入的蟲子是否是同性(同組) 如果攪基,利用變量記錄;

4.我能開火車了,污,污。。。。

代碼:

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

int par[100020];
int rank[100000];

void init(int x)//初始化
{
    for(int i = 0; i < x; i++)
    {
         par[i] = i;
         rank[i] = 0;
    }
}
int find(int x)//查找根節點
{
    if(par[x] == x) return x;
    else
        return par[x] = find(par[x]);
}
void unite(int x, int y)//合併
{
    x = find(x);
    y = find(y);
    if(x == y) return ;
    if(rank[x] < rank[y])
         par[x] = y;
    else{
        par[y] = x;
        if(rank[x] == rank[y]) rank[x]++;
    }
}
bool same(int x, int y)//判斷x, y是否是一組
{
    return par[x] == par[y];
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int k = 0; k < n;k++)
    {
        int a,b,c,d;
        scanf("%d%d",&a,&b);
        init(2 * a);
        int txt = true;//記錄變量
        for(int i = 0; i < b;i++)
        {
            scanf("%d%d",&c,&d);
            if(same(c,d))//判斷是否是一組(同性)其實還有same(c + a,d + a)自己想去吧 
            {
                txt = false;
            }
            unite(c, d + a);//兩個蟲子異性合併
            unite(c + a,d);//同上
        }
        if(k) printf("\n");//不加這肯定TE
        if(!txt) printf("Scenario #%d:\nSuspicious bugs found!\n",k + 1);
        if(txt) printf("Scenario #%d:\nNo suspicious bugs found!\n",k + 1);
    }
    return 0;
}

 

隊友版本:

 

 

 

#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<stack>
#include<queue>

using namespace std;

int n,k;
int parent[1000000];

int find(int a)
{
    if(a!=parent[a])
        return parent[a]=find(parent[a]);
    else
        return parent[a];
}

void unite(int a,int b)
{
    a=find(a);
    b=find(b);
   parent[b]=a;
}

int main()
{
    int t,i,x,y,sum=1;
    scanf("%d",&t);
    while(t--)
   {
   scanf("%d%d",&n,&k);
   for(i=1;i<=n*2;i++)
   {
       parent[i]=i;
   }
   int ans=0;
    for(i=0;i<k;i++)
    {
        scanf("%d%d",&x,&y);
        if(find(x)==find(y))
        {
           ans=1;
        }
        else
            {

                unite(x,y+n);
                unite(x+n,y);
            }
    }
  printf("Scenario #%d:\n",sum++);
 if(ans==1)
    printf("Suspicious bugs found!\n");
  else
    printf("No suspicious bugs found!\n");
    if (t>0)
        printf("\n");
   }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章