PAT甲級:1064 Complete Binary Search Tree (30分)

PAT甲級:1064 Complete Binary Search Tree (30分)

題幹

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

      
    

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路

抓住兩個點:

  • BST的中序歷遍的結果是有序的。
  • 用數組建CBT可以完全利用空間,不必考慮具體的長度問題,

我們利用這兩個點,將原數據進行排序後,遞歸建立一個數組樹。建立好之後,數組的結果就是層序歷遍的結果。

code

#include <iostream>
#include <algorithm>
#include <vector>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
using namespace std;
int cnt = 0;
void dfs(vector<int> &order, vector<int> &tree, int index){
	if(index >= order.size()) return;
	dfs(order, tree, index * 2 + 1);
	tree[index] = order[cnt++];
	dfs(order, tree, index * 2 + 2); 
}
int main(int argc, char** argv) {
	int n = 0;
	scanf("%d", &n);
	vector<int> order(n), tree(n);
	for(int i = 0; i < n; i++) scanf("%d", &order[i]);
	sort(order.begin(), order.end());
	dfs(order, tree, 0);
	for(auto it = tree.begin(); it != tree.end(); it++){
		if(it != tree.begin()) printf(" ");
		printf("%d", *it);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章