PTA_PAT甲级_1004 Counting Leaves (30分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:
给出树各个非叶节点对应的子节点,输出各深度的叶节点数

分析:
用vector数组存各个节点的子节点,用数组存储各深度叶节点数,DFS各个节点,DFS两个参数分别为当前节点编号和当前深度,若当前节点为叶节点则作为递归基返回,否则DFS其所有子节点,每次DFS顺便更新树高

代码:

#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

int N, M;
int leaf[100]={0}, depth=1;//每层叶节点数,树高//按题意根为1//0也可以//用来控制末尾空格
vector<int> G[100];

void DFS(int ID, int tmpd){//当前节点编号,当前所在深度
	depth = max(tmpd,depth);//所有访问过的节点的深度最大值即为树高
	if(G[ID].size()==0){//如果当前节点为叶节点//递归基
		leaf[tmpd]++;
    	return;//返回给上层调用
	}
	for(int i=0;i<G[ID].size();i++)//检查当前节点的每个子节点
  		DFS(G[ID][i],tmpd+1); 
}

int main()
{
  cin>>N>>M;
  for(int i=0;i<M;i++){
	int ID, K;
    cin>>ID>>K;
    for(int j=0;j<K;j++){
    	int tmp;
    	cin>>tmp;
    	G[ID].push_back(tmp);
    }
  }
  DFS(1,1);
  cout<<leaf[1];
  for(int i=2;i<=depth;i++) cout<<' '<<leaf[i];
  return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章