7-5 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

作者: 陳越

單位: 浙江大學

時間限制: 400 ms

內存限制: 64 MB

代碼長度限制: 16 KB

 

#include <iostream>
#include <string>
#include <stack>
using namespace std;

int cnt=0;

void funpost(int* prev,int* midv,int len){
    if(len==0)
        return;
    int rootindex=0;
    for(rootindex=0; prev[0]!=midv[rootindex]; rootindex++);
    funpost(prev+1,midv,rootindex);
    funpost(prev+rootindex+1,midv+rootindex+1,len-rootindex-1);
    cout<<*prev;
    if(cnt>1)
        cout<<" ";
    --cnt;
}

int main(int argc, const char * argv[]) {
    int n;
    scanf("%d",&n);
    stack<int> s;
    int midv[n],prev[n];
    int mindex=0,preindex=0;
    for (int i=0; i<2*n; i++) {
        string tmp;
        int input;
        cin>>tmp;
        if (tmp.compare("Pop")==0) {
            midv[mindex]=s.top();
            mindex++;
            s.pop();
        }else{
            cin>>input;
            prev[preindex]=input;
            preindex++;
            s.push(input);
        }
    }
    cnt=n;
    funpost(prev,midv,n);
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章