【PAT甲級】1041 Be Unique(散列)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10​4​​]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

 題目大意

這題就是要找到一個數列中的第一個在整個數列中唯一的數字,如果沒有則輸出None

個人思路

這題是散列算法的應用。設立一個統計個數的數組num_cnt[],num_cnt[i]表示i在數列中出現的次數,然後輸出數列中第一個數量爲1的數字即可,如果沒有則輸出None

代碼實現

#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <vector>
#include <cmath>
#include <algorithm>
#include <iostream>
#define ll long long
#define eps 1e-8
#define INF 0x7FFFFFFF
using namespace std;
const int maxn = 100005;
const int maxm = 10005;
int nums[maxn];
int nums_cnt[maxm];

int main() {
    // 初始化
    memset(nums_cnt, 0, sizeof(nums_cnt));
    // 輸入並統計個數
    int n;
    cin >> n;
    for (int i = 0; i < n; i ++) {
        cin >> nums[i];
        nums_cnt[nums[i]] ++;
    }
    // 輸出
    for (int i = 0; i < n; i ++) {
        if (nums_cnt[nums[i]] == 1) {
            cout << nums[i] << endl;
            return 0;
        }
    }
    cout << "None" << endl;
    return 0;
}

總結

學習不息,繼續加油

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章