【PAT甲級】1070 Mooncake(貪心)

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

題目大意

這題就是給出月餅的種類數、需要賣出的、然後給出每種月餅存量和總售價。求出賣出需要賣出月餅的最大收益。

個人思路

這題是典型的貪心問題,只要求出每個月餅的平均利潤(單價),然後從高到低排序,再賣到目標數量就可以啦。

【注:這題是乙級的1020】

代碼實現

#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <iostream>

using namespace std;

int const maxn = 1005;

struct mooncake {
	double backup, price, profit;
};

mooncake mooncakes[maxn];

bool cmp(const mooncake m1, const mooncake m2) {
	return m1.profit > m2.profit;
}

int main() {
	//輸入 
	int n, need;
	cin >> n >> need;
	for (int i = 0; i < n; i ++) {
		cin >> mooncakes[i].backup;
	}
	for (int i = 0; i < n; i ++) {
		cin >> mooncakes[i].price;
		mooncakes[i].profit = mooncakes[i].price / mooncakes[i].backup;
	}
	
	// 排序 
	sort(mooncakes, mooncakes+n, cmp);
	
	// 貪心 
	double sum = 0.0, ans = 0.0;
	for (int i = 0; i < n; i ++) {
		if (mooncakes[i].backup == 0) {
			continue;
		}
		// 這款月餅全賣了還不夠
		if (sum + mooncakes[i].backup <= need) {
			sum += mooncakes[i].backup;
			ans += mooncakes[i].price;
		}
		// 這款月餅買一部分就可以啦
		else {
			ans += (need - sum) * mooncakes[i].profit;
			break;
		}
	}
	// 輸出
	printf("%.2lf",ans);
	return 0;
}

總結

學習不息,繼續加油

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章