week15作业A ZJM 与霍格沃兹

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题

题库格式:[魔咒] 对应功能

背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能

ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

输入:
首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出:
每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

输入样例:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky

输出样例:
light the wand
accio
what?
what?

Bkdr Hash算法:
建立两个map,m1和m2,通过Bkdr Hash算法算出魔咒和对应功能的哈希值hash1和hash2
m1[hash1]=index,str1[index]=魔咒
m2[hash2]=index,str2[index]=对应功能
根据查询的是魔咒还是对应功能在对应的map中查询,如果map.find(hash)返回的结果是map.end(),则说明这个魔咒或功能在魔咒词典中不存在,输出what?;否则,返回的是数组中相应的索引index,输出即可。
在计算哈希值时,因为字符串最长为80,所以可以用快速幂来所短时间;当然也可以不用,只不过从seed^1开始逐渐累加即可。

#include<iostream>
#include<map>
#include<string>
#include<string.h>
#define ll long long
#define seed 7
using namespace std;
int N,len;
ll mod=1e9+7;
string str1[110000],str2[110000];
map<ll,int> m1,m2;
ll quick_pow(int x,int a)
{//快速幂 
	ll ans=1;
	while(x>0)
	{
		if(x&1) ans=ans*a;
		a=a*a;
		x>>=1;
	}
	return ans;
}
ll func(string s)
{
	ll tmp=0;
	for(int i=s.size()-1;i>=0;i--)
	{
		int t=s.size()-i;
		tmp=tmp+quick_pow(t,seed)*(ll)s[i];
		tmp=tmp%mod;
	}
	tmp%=mod;
	return tmp;
}
int main()
{
	int cnt=0;
	while(1)
	{
		string str;
		getline(cin,str);
		if(str=="@END@")
			break;
		int flag=0;
		for(int i=1;i<str.size();i++)
		{
			if(flag==0&&str[i]!=']')
			{
				str1[cnt]+=str[i];
			}
			else if(flag==0&&str[i]==']')
			{
				i++;
				flag=1;
			}
			else if(flag==1)
			{
				str2[cnt]+=str[i];
			}
		}
		ll tmp1=func(str1[cnt]),tmp2=func(str2[cnt]);
		m1[tmp1]=cnt;
		m2[tmp2]=cnt; 
		cnt++;
	}
	cin>>N;
	string str;
	ll tmp;
	getchar();
	for(int i=0;i<N;i++)
	{
		getline(cin,str);
		if(str[0]=='[')
		{
			str.erase(str.size()-1,1);
			str.erase(0,1);
			tmp=func(str);
			if(m1.find(tmp)==m1.end())
			{
				cout<<"what?\n";
			}
			else
			{
				int index=m1[tmp];
				cout<<str2[index]<<'\n';
			}
		}
		else
		{
			tmp=func(str);
			if(m2.find(tmp)==m2.end())
			{
				cout<<"what?\n";
			}
			else
			{
				int index=m2[tmp];
				cout<<str1[index]<<'\n';
			}
		}
	}
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章