poj - 2411 Mondriaan's Dream

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.


Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare!

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.

Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.

Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

思路:

状态压缩dp,dp[i][j]表示第i行状态为j时的所有放置方法。比如dp[1][6]表示第1行状态为6(二进制为0110,即第2,3列放置,第1,4列空置)。

第一行无法竖着放置,因此将第0行放满的情况设置为1。

依照从上到下,从左到右的顺序,每次扫描到每一行的最后一列为止。

答案是要求填满,所以最后打印第m行放满的值即可。

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
 
typedef long long ll;
const int MAXN = 13;
ll dp[MAXN][1 << MAXN];
int n, m;
 
//next is the state of next row
void dfs(int row, int column, int state, int next)
{
	if (column == n)
	{
		dp[row+1][next] += dp[row][state];		
		return;								
	}
	else
	{
		//place a 1*2(width = 1 & height = 2) board
		if ((state & (1 << column)) == 0)	
		{
			dfs(row, column + 1, state, next | (1 << column));
		}
		
		//place a 2*1 board
		if (column + 1 < n && (state & (1 << column)) > 0 && (state & (1 << (column + 1))) > 0)	
		{													
			dfs(row, column + 2, state, next | (1 << column) | (1 << (column + 1)));
		}
		
		//do not place
		if ((state & (1 << column)) > 0)	
		{
			dfs(row, column + 1, state, next);
		}
	}
}
 
int main()
{
	while (~scanf("%d%d", &n, &m) && (n + m))
	{
		if(n > m)	
		{
			swap(m, n);
		}
		memset(dp, 0, sizeof(dp));
		dp[0][(1 << n) - 1] = 1;
		
		for (int i = 0; i < m; i++)		 
		{
			for (int state = 0; state < (1 << n); state++)
			{
				if (dp[i][state] > 0)	 
				{
					dfs(i, 0, state, 0);
				}
			}
		} 
		cout << dp[m][(1 << n) - 1] << endl;
	}
	return 0;
} 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章