LightOJ 1104 Birthday Paradox【概率】

參看資料:

https://baike.baidu.com/item/%E7%94%9F%E6%97%A5%E6%82%96%E8%AE%BA

http://www.cnblogs.com/-maybe/p/4521247.html


題目:

Sometimes some mathematical results are hard to believe. One of the common problems is the birthday paradox. Suppose you are in a party where there are 23 people including you. What is the probability that at least two people in the party have same birthday? Surprisingly the result is more than 0.5. Now here you have to do the opposite. You have given the number of days in a year. Remember that you can be in a different planet, for example, in Mars, a year is 669 days long. You have to find the minimum number of people you have to invite in a party such that the probability of at least two people in the party have same birthday is at least 0.5.

Input

Input starts with an integer T (≤ 20000), denoting the number of test cases.

Each case contains an integer n (1 ≤ n ≤ 105) in a single line, denoting the number of days in a year in the planet.

Output

For each case, print the case number and the desired result.

Sample Input

2

365

669

Sample Output

Case 1: 22

Case 2: 30

題目大意: 

       給出n,表示一年有n天,求一個人至少邀請多少個人,纔可以至少有2個人同時生日的概率>=0.5;

解題思路:

       我們知道有一個有關於生日的結論:就是如果有23個人同時在一個教室,則這個教室至少有2個人同時生日的概率>50%。

       設p(i)表示教室有i個人,但是沒有人同時生日的概率。

       則:p(1)=1

              i>1時:第一個人有365種選擇,第2個人只有364種選擇,第3個人有363種選擇....

              則:p(i)=(365/365)*(364/365)*(363/365)*...*((365-i+1)/365)

                          =(265*364*...*(366-i))/(365^i);

              則當p(i)<=0.5時,至少2個人同時生日的概率爲1-p(i)>=0.5;

              經過計算:當i=23時,p(23)<=0.5。

       這道題的題意:如果一年不是有365天呢?

       給出n,表示一年有n天,求一個人至少邀請多少個人,纔可以至少有2個人同時生日的概率>=0.5;

       PS:

              1>邀請多少個人,所以p(i)<=0.5後,輸出的是i-1;

              2>如果一年只有1天的話,需要邀請1;

              3>由於當n=10^5的時候,i只比300多一點,所以在循環的時候,直接i<=400;

實現代碼:

#include<cstdio>
#include<iostream>
const int exp=1e-8;
inline int sgu(double a){
    return (a>exp ) - ( a< -exp);
}

int main(){
    int test;
    scanf("%d",&test);
    int cas=1;
    while(test--){
        int n;
        scanf("%d",&n);
        double p=1.0;
        int ans=0;
        for(int i=2;i<=400;i++){
            p=p/(double)n*(double)(n-i+1);
            if(sgu(p-0.5)<=0){
                ans=i;
                break;
            }
        }
        if(ans>1)
            ans--;
        printf("Case %d: %d\n",cas++,ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章