PKU-1080 Human Gene Functions

原题链接 http://poj.org/problem?id=1080

Human Gene Functions
 
Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and  determining  their  functions,  because  these  can  be  used  to  diagnose  human  diseases  and  to  design  new drugs for them.

A human gene can be  identified  through a  series of  time-consuming biological experiments, often with  the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database  search will  return a  list of gene  sequences  from  the database  that are  similar to  the query gene.
Biologists  assume  that  sequence  similarity  often  implies  functional  similarity.  So,  the  function  of  the  new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG  to  result  in –GT--TAG. A  space  is denoted by  a minus  sign  (-). The  two genes are now of  equal
length. These two strings are aligned: 

AGTGAT-G
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth,  and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

  denotes  that  a  space-space match  is  not  allowed. The  score  of  the  alignment  above  is  (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of  (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T  test cases. The number of test cases  ) (T  is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

 

Source Code
/*
观察题目给出的一个最优解: 
AGTGATG 
-GTTA-G 
将其从某一处切开,如果左边部分的分值不是最大,那么将其进行调整,使其分值变大,
则整个解分值变大,与已知的最优矛盾。所以左边部分的分值必是最大。
同理,右边也是。可见满足最优子结构的性质。考虑使用DP: 

  设两个DNA序列分别为s1,s2,长度分别为len1,len2,score为分值表。
  f[i,j]表示子串s1[1..i]和s2[1..j]的分值。考虑一个f[i,j],我们有: 
  
	1.s1取第i个字母,s2取“-”:f[i-1,j] + score[s1[i],'-'] 
	
	2.s1取“-”,s2取第j个字母:f[i,j-1] + score['-',s2[j]] 
	  
	3.s1取第i个字母,s2取第j个字母:f[i-1,j-1] + score[s1[i],s2[j]] 
		
	即f[i,j] = max(f[i-1,j] + score[s1[i],'-'], f[i,j-1] + score['-',s2[j]], f[i-1,j-1] + score[s1[i],s2[j]]); 
		  
	然后考虑边界条件,这道题为i或j为0的情况。 
	当i=j=0时,即为f[0,0],这是在计算f[1,1]时用到的,根据f[1,1] = f[0,0] + score[s1[i], s2[j]],明显有f[0,0] = 0。 
	当i=0时,即为f[0,1..len2],有了f[0,0],可以用f[0,j] = f[0,j-1] + table['-',s2[j]]来计算。 
	当j=0时,即为f[1..len1,0],有了f[0,0],可以用f[i,0] = f[i-1,0] + table[s1[i],'-']来计算。 
			
	至于计算顺序,只要保证计算f[i,j]的时候,使用到的f[i-1,j],f[i,j-1],f[i-1,j-1]都计算出来了就行了。
 所谓划分阶段也就是为了达到这个目的。这样我们使用一个二重循环就可以了。 
*/

#include <iostream>
using namespace std;

#define Max 101
int len1,len2;
char gene1[Max];
char gene2[Max];
int dp[Max][Max];
int value[5][5] ={
				    5,-1,-2,-1,-3,
					-1,5,-3,-2,-4,
					-2,-3,5,-2,-2,
					-1,-2,-2,5,-1,
					-3,-4,-2,-1,0,
				};

int change(char ch){
    if(ch=='A')
        return 0;
    else if(ch=='C')
        return 1;
    else if(ch=='G')
        return 2;
    else if(ch=='T')
        return 3;
}

int main() {
	int i, j, cases;
    while (scanf("%d", &cases) != EOF) {
		while (cases --) {
			scanf("%d %s", &len1, &gene1);
			scanf("%d %s", &len2, &gene2);

			memset(dp, 0, sizeof(dp));

			for(i = 1; i<= len1; i++)
				dp[i][0]=dp[i - 1][0] + value[change(gene1[i - 1])][4];
			for(i = 1;i<= len2;i++)
				dp[0][i]=dp[0][i - 1] + value[4][change(gene2[i - 1])];

			for (i = 1; i <= len1; i++) {
				for (j = 1; j <= len2; j++) {
					int MaxMatch = dp[i - 1][j - 1] + value[change(gene1[i - 1])][change(gene2[j - 1])];
					if (MaxMatch < dp[i - 1][j] + value[change(gene1[i - 1])][4])
						MaxMatch = dp[i - 1][j] + value[change(gene1[i - 1])][4];
					if (MaxMatch < dp[i][j - 1] + value[4][change(gene2[j - 1])])
						MaxMatch = dp[i][j - 1] + value[4][change(gene2[j - 1])];
					dp[i][j] = MaxMatch;
				}
			}
			printf("%d\n", dp[len1][len2]);
		}
     
    }
    return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章