hdu_1686 Oulipo

Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
1 3 0
這題與常規kmp算法稍微改變一點就行了。首先next數組要多保存一個值,存儲最後一個字符的匹配情況。
另外當字符穿完全匹配時。不要立即返回,而應該讓統計次數+1後,根據next數組最後一個值,繼續尋找匹配字符串。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 10001
#define M 1000001
char s1[N];
char s2[M];
void GetNext(const char s[],int next[]){
    int k = -1,j = 0;
    next[0] = -1;
    while(j < (int)strlen(s1)){
        if(k == -1 || s[k] == s[j]){
            ++k;
            ++j;
            next[j] = k;
        }
        else k = next[k];
    }
}
int KMP(const char s1[],const char s2[]){
    int l1 = strlen(s1);
    int l2 = strlen(s2);
    int next[l1+1];
    GetNext(s1,next);
    int i, j, n = 0;
    i = 0;
    j = 0;
    while(i < l2){
        if(j == -1 || s1[j] == s2[i]){
            ++i;
            ++j;
        }
        else j = next[j];
        if(j == l1){
            ++n;
            j = next[j];
        }
    }
    return n;
}
int main(){
    int n;
    scanf("%d",&n);
    while(n--){
        scanf("%s%s",s1,s2);
        printf("%d\n",KMP(s1,s2));
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章