PAT-1064 Complete Binary Search Tree(完全二叉樹)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10

1 2 3 4 5 6 7 8 9 0


Sample Output:

6 3 8 1 5 7 9 0 2 4


題目大意:給出一個構成完全二叉樹(除了最後一層的右邊可能缺少部分節點,其餘層均達到最大節點數)的序列,要求輸出該完全二叉樹的層次遍歷。


主要思想:根據完全二叉樹的特性可以用一個數組很方便的表示出來,將根節點的索引設爲1,之後每個索引爲i的節點,其左節點爲2i,右節點爲2i+1,然後對於輸入的序列進行排序後按照中序遍歷依次填入二叉樹數組,這樣完全二叉樹就構造成功了,而最後一步的層次遍歷輸出其實就是對數組的順序輸出。

#include <cstdio>
#include <algorithm>
int n;						//節點個數
int index = 0;				//序列數組的索引
int a[1005];				//輸入的序列數組
int node[1005];				//完全二叉樹數組
using namespace std;

void travel(int i) {
    if (i > n)  return;
    travel(2*i);
    node[i] = a[index++];
    travel(2*i+1);
}

int main(void) {
    int i;
    
    scanf("%d", &n);
    for (i = 0; i < n; i++) {
        scanf("%d", &a[i]);
    }
    sort(a, a+n);
    travel(1);				//中序遍歷構造完全二叉樹
	//層次遍歷輸出
    for (i = 1; i < n; i++)
        printf("%d ", node[i]);
    printf("%d\n", node[i]);

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章