HDU1241Oil Deposits(DFS)

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*’, representing the absence of oil, or @’, representing an oil pocket.

Output
are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

題意:
只要連在一起的就算是一個油袋,並且連在一起具有連帶性(只要有關聯),檢查所給地圖一共有幾個油袋?
解題思路:
用深搜從(0,0)去遍歷每一個點,找到他附近的油,並把遍歷到的油都變爲*,以便於在以後的遍歷中再次以已經遍歷過得油爲基點遍歷;
Accept Code :

#include <stdio.h>
char map[102][102];
int n,m;
void dfs(int x,int y)
{
	int xx,yy;
	map[x][y]='*';
	for(xx=-1; xx<=1; xx++)
	{
		for(yy=-1; yy<=1; yy++)
		{
			int tx=x+xx;
			int ty=y+yy;
			if(tx>=0&&ty>=0&&tx<n&&ty<m&&map[tx][ty]=='@')
			   dfs(tx,ty);
		}
	}
	return ;
}
int main()
{
	while(scanf("%d %d", &n,&m)==2)
	{
		int step=0,i,j;
		if(m==0||n==0) break;
		for(i=0; i<n; i++)
			scanf("%s", map[i]);
		for(i=0; i<n; i++)
		{
			for(j=0; j<m; j++)
			{
				if(map[i][j]=='@')
				{
					 dfs(i,j);
				    step++;
				}	 
			}
		}
		printf("%d\n", step);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章