hdu_2574 Hdu Girls' Day

Hdu Girls' Day

2014-8-1 20:23

Problem Description
Hdu Girls' Day is a traditional activity in Hdu. Girls in Hdu participate in the activity and show their talent and skill. The girls who win in the activity will become the Hdu's vivid ambassadors(形象大使). There are many students in Hdu concern the activity. Now it's the finally competition to determine who will be the Hdu's vivid ambassadors. The students vote for the girl they prefer. The girl who has the most number of votes will be the first. You as a student representing Hdu Acm team has a chance to vote. Every girl who participates in the activity has an unique No. and name. Because you very like prime number, you will vote for the girl whose No. has the maximum number of unique prime factors.

For example if the girl's No. is 12, and another girl's No. is 210, then you will choose the girl with No. 210. Because 210 = 2 *3 * 5*7 , 12 = 2*2*3. 210 have 4 unique prime factors but 12 just have 2. If there are many results, you will choose the one whose name has minimum lexicographic order.
 

Input
The first line contain an integer T (1 <= T <= 100).Then T cases followed. Each case begins with an integer n (1 <= n <= 1000) which is the number of girls.And then followed n lines ,each line contain a string and an integer No.(1 <= No. <= 2^31 - 1). The string is the girl's name and No. is the girl's No.The string's length will not longer than 20.
 

Output
For each case,output the girl's name who you will vote.
 

Sample Input
2 3 Kate 56 Lily 45 Amanda 8 4 Sara 55 Ella 42 Cristina 210 Cozzi 2
 

Sample Output
Kate Cristina
 

#include<stdio.h>
#include<string.h>
#define maxn 1000000
int a[maxn]={0,0};
void count()
{
     for(int i=2;i*i<maxn;i++)
     {
       if(!a[i])
       {
         for(int j=i*i;j<maxn;j+=i)
           a[j]=1;
       }
     }
}
int main()
{
    count();
    int T,num,k,shu,max,n,q;
    char name[22],s[22];
    scanf("%d",&T);
    while(T--)
    {
      max=-1;
      scanf("%d",&n);
      while(n--)
      {
       shu=0;q=0;
       scanf("%s%d",&name,&num);
       for(k=2;k<=num;k++)
       {
          if(a[k])  continue;
          else
          {
             if(num%k==0)
             {
                if(k!=q) shu++;
                q=k;
                num=num/k;
             }
          }
       }
       if(shu>max)
       {
           max=shu;
           strcpy(s,name);
       }
       else if(max==shu)
       {
            if(strcmp(name,s)<0)   //name是當前的,s是之前存的,若當前的更小,就把當前的存入s 
              strcpy(s,name);
       }
      }
      printf("%s\n",s);
    }
    return 0;
}

            
                 
       

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章