[整數拆分] Ignatius and the Princess III

Problem Description

“Well, it seems the first problem is too easy. I will let you know how foolish you are later.” feng5166 says.

“The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+…+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that “4 = 3 + 1” and “4 = 1 + 3” is the same in this problem. Now, you do it!”

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input

4
10
20

Sample Output

5
42
627

題目大意

對某個整數n拆分,問一共有多少種拆分的方法

題目解析

這是一個母函數的板子題,但是今天我們來用dp來做一下
用一個一維數組dp來記錄,dp【j】表示拆分j有多少種方法。我們對dp數組進行n次更新,第i次表示前i個數來組合會有多少中方法,dp[j]+=dp[j-i],意思就是我們的dp[j]中已經記錄了前i-1個數組成j的個數,現在的dp[j]再加上dp[j-i]即可,因爲是從前往後更新,所以每個數都有機會使用多次,跟多重揹包有異曲同工之妙。

AC代碼

#include<bits/stdc++.h>
using namespace std;
const int maxn=130;

int n;
int dp[maxn];

int main(){
	while(scanf("%d",&n)!=EOF){
		memset(dp,0,sizeof dp);
		dp[0]=1;
		for(int i=1;i<=n;i++){
			for(int j=i;j<=n;j++)
				dp[j]+=dp[j-i]; 
		}
		cout<<dp[n]<<endl;
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章