POJ 1004

POJ 1004

原題
Description

Larry graduated this year and finally has a job. He’s making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what’s been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
Sample Input

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output

$1581.42

翻譯
描述

拉里今年畢業,終於找到了工作。他賺了很多錢,但是似乎永遠都還不夠。拉里已決定,他需要掌握自己的金融資產並解決其融資問題。第一步是弄清楚他的錢怎麼了。拉里(Larry)有他的銀行帳戶對帳單,想看看他有多少錢。通過編寫程序來幫助拉里獲取過去十二個月中每個月的期末餘額,並計算其平均帳戶餘額。
輸入項

輸入將是十二行。每行將包含其特定月份銀行帳戶的期末餘額。每個數字都是正數並顯示在便士中。不包括美元符號。
輸出量

輸出將是一個數字,即十二個月期末餘額的平均值(均值)。它會四捨五入到最接近的一分錢,並立即在前面加一個美元符號,然後在行尾。輸出中將沒有其他空格或字符。
樣本輸入

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
樣本輸出

$ 1581.42

下面是AC代碼,需要注意的就是輸出格式

#include <stdio.h>
int main()
{
	int i;
	float month[12];
	float sum=0;
	for(i=0;i<12;++i)
	{
		scanf("%f",&month[i]);
		sum+=month[i];
	}
	printf("$%.2f\n",sum*1.0/12);
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章