hdu 2087 剪花布條 KMP水題。。

剪花布條

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10399    Accepted Submission(s): 6701


Problem Description
一塊花布條,裏面有些圖案,另有一塊直接可用的小飾條,裏面也有一些圖案。對於給定的花布條和小飾條,計算一下能從花布條中儘可能剪出幾塊小飾條來呢?
 

Input
輸入中含有一些數據,分別是成對出現的花布條和小飾條,其布條都是用可見ASCII字符表示的,可見的ASCII字符有多少個,布條的花紋也有多少種花樣。花紋條和小飾條不會超過1000個字符長。如果遇見#字符,則不再進行工作。
 

Output
輸出能從花紋布中剪出的最多小飾條個數,如果一塊都沒有,那就老老實實輸出0,每個結果之間應換行。
 

Sample Input
abcde a3 aaaaaa aa #
 

Sample Output
0 3
 實在沒什麼要注意的。
代碼:
#include <stdio.h>
#include <string.h>
#define SIZE 1100

char t[SIZE] , des[SIZE] ;
int next[SIZE] ;

void getNext()
{
	int len = strlen(t) ;
	int i = -1 , j = 0 ;
	next[0] = -1 ;
	while(j<len)
	{
		if(i == -1 || t[i] == t[j])
		{
			++i,++j;
			next[j] = i ;
		}
		else
		{
			i = next[i] ;
		}
	}
}

int kmp()
{
	int i = 0 , j = 0 ;
	int len1 = strlen(t) , len2 = strlen(des) ;
	int c = 0 ;
	getNext() ;
	while(j<len2)
	{
		if(i == -1 || t[i] == des[j])
			++i ,++j;
		else
			i = next[i] ;
		if(i == len1)
		{
			i = 0 ;
			c++ ;
		}	
	}
	return c ;
}

int main()
{
	while(~scanf("%s",des) && strcmp(des,"#")!=0)
	{
		scanf("%s",t) ;
		int ans = kmp() ;
		printf("%d\n",ans) ;
	}
	return 0  ;
}

與君共勉
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章