HDU 1005 Number Sequence(找規律)

題目鏈接:http://acm.hdu.edu.cn/showproblem.php?pid=1005

 

 

Number Sequence

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 179056    Accepted Submission(s): 44500

 

 

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

 

 

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

 

 

Output

For each test case, print the value of f(n) on a single line.

 

 

Sample Input


 

1 1 3 1 2 10 0 0 0

 

 

Sample Output


 

2 5

 

 

Author

CHEN, Shunbao

 

 

Source

ZJCPC2004

 

 

Recommend

JGShining   |   We have carefully selected several similar problems for you:  1008 1021 1019 1009 1012 

 

 

Statistic | Submit | Discuss | Note

 

 

題意:給出A, B,n, 求出f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7的值。其中1 <= A, B <= 1000, 1 <= n <= 100,000,000。顯然是不能直接計算的,我們可以找規律。f(n)是要mod7的,所以f(n)的值最多隻會有7*7 = 49種。找出了規律,寫起來就會簡短很多。

 

 

# include<iostream>
# include<cstdio>
# include<cstring>
using namespace std;
int f[50];

int main() {
	int a, b, n;
	while(~scanf("%d %d %d", &a, &b, &n)) {
		if(a == 0 && b == 0 && n == 0)
			break;
		
		f[1] = 1;
		f[2] = 1;
		for(int i = 3; i <= 48; i ++)
			f[i] = (a*f[i - 1] + b*f[i - 2])%7;
			
		printf("%d\n", f[n%49]);
	}
	return 0;
}

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章