POJ 3279 Fliptile(枚舉+模擬)

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

題意:
給你一個N*M的01矩陣,每次按一個位置,會將這個位置和其上下左右的數字反轉,問按哪幾個位置且按的次數最少,使得矩陣全變爲0。若不能完成,則輸出“IMPOSSIBLE”。

題解:
我們可以發現,當這一行的狀態確定後,下一行的狀態也就只有了唯一的解。我們可以通過改變下一行某個位置的狀態來使這一行同列的位置狀態改變且不會影響到這一行其他位置的狀態。這樣的話,我們可以通過枚舉第一行的所有狀態來找出最優解。

#include<iostream>
#include<cstdio>
using namespace std;
int a[20][20];//記錄初始狀態 
int used[20][20];//記錄按哪些開關 
int b[20][20];//模擬狀態轉換 
int ans[20][20];//記錄最優解 
int n,m;
int step=1e7;//記錄按的次數 
void del()//模擬 
{
	for(int i=2;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			used[i][j]=0;
		}
	}
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			b[i][j]=a[i][j];
		}
	}
	for(int i=1;i<=m;i++)
	{
		if(used[1][i])
		{
			sum++;
			b[1][i-1]^=1;
			b[1][i+1]^=1;
			b[2][i]^=1;
			b[1][i]^=1;
		}
	}
	for(int i=2;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(b[i-1][j])
			{
				sum++;
				used[i][j]=1;
				b[i][j]^=1;
				b[i-1][j]^=1;
				b[i+1][j]^=1;
				b[i][j-1]^=1;
				b[i][j+1]^=1;
			}
		}
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(b[i][j])//不滿足全爲0 
			{
				return;
			}
		}
	}
	if(sum<step)//更新最優解 
	{
		step=sum;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				ans[i][j]=used[i][j];
			}
		}
	}
}
void dfs(int x)//枚舉第一行狀態 
{
	if(x>m) 
	{
		del();
		return;
	}
	for(int i=0;i<=1;i++)
	{
		used[1][x]=i;
		dfs(x+1);
		used[1][x]=0;
	}
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
    	for(int j=1;j<=m;j++)
    	{
    		scanf("%d",&a[i][j]);
    	}
    }
    dfs(1);
    if(step==1e7)
    {
    	printf("IMPOSSIBLE");
    }
    else
    {
    	for(int i=1;i<=n;i++)
    	{
    		for(int j=1;j<=m;j++)
    		{
    			printf("%d ",ans[i][j]);
    		}
    		printf("\n");
    	}
    }
    return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章