ACM入門之杭電1045:Fire Net C++解法

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2957    Accepted Submission(s): 1700


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
5 1 5 2 4
 

Source
#include<iostream>
using namespace std;
int count = 0, n = 0;
//判斷該ch[x][y]是否可以放置
bool isOk(char **ch, int x, int y){
	int i;
	//向上檢索
	for (i = x - 1; i >=0; --i){
		if(ch[i][y]=='0'){
			return false;
		}
		//碰到牆
		if(ch[i][y] == 'X'){
			break;
		}
	}
	//向左檢索
	for (i = y - 1; i >=0; --i){
		if(ch[x][i]=='0'){
			return false;
		}
		//碰到牆
		if(ch[x][i] == 'X'){
			break;
		}
	}
	return true;
}
void search(char **ch, int k, int step){
	int x, y;
	if(k == n * n){//到達最末
		//是否大於之前的count
		if(step > count){
			count = step;
			return;
		}
	}else {
		x = k / n;//行數
		y = k % n;//列數
		if(ch[x][y] == '.' && isOk(ch, x, y)){
			ch[x][y] = '0';
			search(ch, k+1, step+1);//進入k+1步的搜索
			//關鍵理解下面兩句!回溯!
			ch[x][y] = '.';//重新賦值爲'.',爲了下一輪的搜索
			search(ch, k+1, step);
		}else {
			//ch[x][y]不爲'.',進入k+1步
			search(ch, k+1, step);
		}
	}
	return;
}
int main(){
	while(cin>>n && n){
		count = 0;
		char **ch = new char* [n];
		for(int i = 0; i < n; ++i){
			ch[i] = new char[n];
		}
		for(int j = 0; j < n; ++j){
			for(int k = 0; k < n; ++k){
				cin>>ch[j][k];
			}
		}
		search(ch, 0, 0);
		cout<<count<<endl;
	}
	return 0 ;
}
 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章