結構struct動態數組創建與操作

在做hdoj的1009,本來這道題目不是很難,可是對於struct動態數組操作不是很熟,做了很久,在這裏記錄一下,避免下次繼續出錯。

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25384 Accepted Submission(s): 8029


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.


 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.


 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.


 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1


 

Sample Output
13.333
31.500


代碼如下:

#include<stdio.h>
#include<algorithm>
using namespace std;

struct trade{
	int j;
	int f;
};

bool compare(const trade &a, const trade &b){
	return double(a.j)/double(a.f)>double(b.j)/double(b.f);
}

void main(){
	int m,n;
	double sum;
	while(1){
		sum=0.0;
		scanf("%d %d",&m,&n);
		if(m==-1)
			break;
		trade* array=new trade[n];
		for(int i=0; i<n; i++){
			scanf("%d %d",&array[i].j,&array[i].f);
		}
		sort(array,array+n,compare);
		for(int j=0; j<n; j++){
			if(m<array[j].f){
				sum+=double(array[j].j)/double(array[j].f)*m;
				break;
			}
			m-=array[j].f;
			sum+=array[j].j;
		}
		printf("%.3f\n",sum);
		delete []array;
	}
}


其中,創建動態struct數組

struct struct_name * struct_array = new struct_name[struct_array_len];

輸入struct數組元素值,記得不要落下&

scanf("%d",&struct_array[i].struct_member);

排序

sort(struct_array,struct_array+struct_array_len,compare);

釋放

delete []struct_array;

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章