hdu1224 dp動態規劃+圖論

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5837 Accepted Submission(s): 1868

Problem Description
Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It’s a good chance to relax themselves. To most of them, it’s the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company’s statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input
The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output
For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input
2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output
CASE 1#
points : 90
circuit : 1->3->1
CASE 2#
points : 90
circuit : 1->2->1

題目的意思: 就是給你一張地圖, 上面有幾十可以旅行的城市, 每個城市有一定的旅行價值(interesting point), 有些城市不能直飛, 問從城市1遊玩到n+1城市怎麼走旅行價值最高. n+1 和 1 是同一個城市. 1和n+1的旅行價值都爲0. 城市編號大的城市到編號小的城市確定沒有直飛航線.

輸入說明:第一行說明測試數據的組數, 然後有一個數字n代表城市數量, 接下來有n個數字代表這些城市的旅行價值.接着是一個數M, 說明有幾條直飛的航線, 然後是M行, 每行有兩個數字, 第一個數字代表起飛城市, 第二個數字代表目的城市.

一開始我差點直接用Floyd了, 然後發現還要求路線, Floyd記錄不了路線.

不難得出狀態轉移方程: 從城市1到城市k的旅行價值=從城市1到城市j的旅行價值 +k城市的旅行價值 (城市j到城市k有直飛的路線, 並且j

#include<cstdio>
#include<cstring>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int cityIns[110];
int edge[110][110];
int track[110];
int dp[110];
int main(){
    //freopen("hdu1224.in", "r", stdin);
    //freopen("hdu.out", "w", stdout);
    int t,cse,n,i,j,m;
    cin>>t;
    for(cse=1;cse<=t;cse++){
        memset(cityIns,0,sizeof(cityIns));
        memset(edge, 0, sizeof(edge));
        memset(track, 0, sizeof(track));
        memset(dp, 0, sizeof(dp));
        cin>>n;
        for(i=1;i<=n;i++)scanf("%d", &cityIns[i]);
        cin>>m;
        for(i=1;i<=m;i++){
            int a,b;
            scanf("%d%d", &a, &b);
            if(a>b)swap(a,b);//防坑
            if(a==b)continue;//同上
            edge[a][b]=1;
        }
        for(i=2;i<=n+1;i++){
            int tmp=0;
            dp[i]=cityIns[i];
            for(j=i-1;j>0;j--){
                if(edge[j][i] && dp[j]>=tmp){//這裏是關鍵
                    tmp=dp[j];
                    track[i]=j;//路徑追蹤, 每個城市記錄從哪個城市到這個城市是最優解
                }
            }
            dp[i]+=tmp;
        }
        int pos=n+1;
        vector<int> ans;
        ans.push_back(1);
        while(track[pos]!=1){//反向追蹤
            pos = track[pos];
            ans.push_back(pos);
        }
        if(cse!=1)cout<<endl;
        printf("CASE %d#\n",cse);
        printf("points : %d\n",dp[n+1]);
        printf("circuit : 1");
        for(i=ans.size()-1;i>=0;i--)printf("->%d",ans[i]);
        cout<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章