hdu-1142-A Walk Through the Forest-最短路+記憶化搜索

A Walk Through the Forest


Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
2 4
 

題意:問從1到2有多少條路徑可以走,規則:對於中途A到B這條路徑,如果d(2->B)<d(2->A)則AB這條路徑可以走

思路:先求出2到所有點的最短路,然後進行記憶化搜索

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#include<algorithm>
#define inf 10000000000
using namespace std;
long long w[1005][1005];
int v[1005];
long long d[1005];
int f[1005];
int n;
void solve()
{
    memset(v,0,sizeof(v));
    for(int i=1 ; i <= n ; i++)
        d[i]=inf;
    d[2]=0;
    for(int i=0 ; i < n ; i++)
    {
        long long x,m=inf;
        for(int y=1 ; y <= n ; y++)
            if(!v[y]&&d[y]<=m)
            m=d[x=y];
        v[x]=1;
        for(int y=1; y <=n ; y++)
        {
            if(d[y]>d[x]+w[x][y])
            {
                d[y]=d[x]+w[x][y];
            }
        }
    }
}
int dfs(int pos)
{
    if(pos == 2) return 1;
    if(f[pos]) return f[pos];
    int xx=0;
    for(int i=1 ; i <= n ; i++)
    {
        if(w[pos][i]>=inf) continue;
        if(d[pos] > d[i])
        {
//            printf("pos=%d i=%d c=%d\n",pos,i,w[pos][i]);
            xx+=dfs(i);
        }
    }
    return f[pos]=xx;
}
int main()
{
    int m,i,j,a,b;
    long long c;
    while(scanf("%d",&n)&&n)
    {
        if(n == 0) break;
        scanf("%d",&m);
        memset(f,0,sizeof(f));
        for(i=0 ; i <= n ; i++)
            for(j=0 ; j <= n ; j++)
                w[j][i]=w[i][j]=inf;
        for(i=0 ; i < m ; i++)
        {
            scanf("%d%d%lld",&a,&b,&c);
            w[a][b]=w[b][a]=c;
        }
        solve();
//        for(int i=1 ; i <= n ; i++)
//            printf("%d ",f[i]);
        printf("%d\n",dfs(1));
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章