L1-8 估值一亿的AI核心代码 (20分) java

AI.jpg

以上图片来自新浪微博。

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

  • 无论用户说什么,首先把对方说的话在一行中原样打印出来;
  • 消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
  • 把原文中所有大写英文字母变成小写,除了 I
  • 把原文中所有独立的 can youcould you 对应地换成 I canI could—— 这里“独立”是指被空格或标点符号分隔开的单词;
  • 把原文中所有独立的 Ime 换成 you
  • 把原文中所有的问号 ? 换成惊叹号 !
  • 在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
 Good to chat   with you
can   you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
 Good to chat   with you
AI: good to chat with you
can   you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don't know

正则表达式,和python的有一点区别,参考了这篇博客

import java.io.IOException;
import java.io.*;
import java.util.*;
import java.util.regex.Matcher;
import java.util.regex.Pattern;

//** Class for buffered reading int and double values *//*
class Reader {
	static BufferedReader reader;
	static StringTokenizer tokenizer;

	// ** call this method to initialize reader for InputStream *//*
	static void init(InputStream input) {
		reader = new BufferedReader(new InputStreamReader(input));
		tokenizer = new StringTokenizer("");
	}

	// ** get next word *//*
	static String next() throws IOException {
		while (!tokenizer.hasMoreTokens()) {
			// TODO add check for eof if necessary
			tokenizer = new StringTokenizer(reader.readLine());
		}
		return tokenizer.nextToken();
	}

	static String nextLine() throws IOException {
		return reader.readLine();
	}
	static char nextChar() throws IOException {
		return next().charAt(0);
	}
	static int nextInt() throws IOException {
		return Integer.parseInt(next());
	}

	static long nextLong() throws IOException {
		return Long.parseLong(next());
	}

	static double nextDouble() throws IOException {
		return Double.parseDouble(next());
	}
}

public class Main {

	public static void main(String[] args) throws IOException {
		Reader.init(System.in);
		int n = Reader.nextInt();
		String[]s = new String[10];
		for (int i = 0; i < n; i++) {
			s[i] = Reader.nextLine();
		}
		for (int i = 0; i < n; i++) {
			System.out.println(s[i]);
			ai(s[i]);
		}
	}

	private static void ai(String s) {
		System.out.print("AI: ");
		//$1表示匹配的第一个括号中的内容,这里要把两个字母中间的多个空格改成一个,所以空格前是一个字母([a-zA-Z]{1}),空格后也是一个字母([a-zA-Z]{1}),中间多个空格变成一个
		String ans = s.replaceAll("([a-zA-Z]{1})\\s+([a-zA-Z]{1})", "$1 $2").trim().replaceAll("\\s+(\\W)", "$1");
		char[]temp = ans.toCharArray();
		for (int i = 0; i < temp.length; i++) {
			if (temp[i]>='A'&&temp[i]<='Z'&&temp[i]!='I') {
				temp[i] = (char) (temp[i]+32);
			}
		}
		ans = new String(temp);
		//因为存在"can you"转换为"I can"之后又将"I"转换为"you"的情况,
        //然后题目要求是输出I can",这样才可以AC
        //所以“can you、could you、I、me”应当是在分割线之上的字符串前提下进行操作。
        //暂时将它们使用ABC代替
		ans = ans.replaceAll("\\bcan you\\b", "A").replaceAll("\\bcould you\\b", "B").replaceAll("\\b(me|I)\\b", "C").replaceAll("[?]", "!").replaceAll("A","I can").replaceAll("B","I could").replaceAll("C","you");
		System.out.println(ans);
	}
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章