Uva 10003 切木棍(dp)

You have to cut a wood stick into pieces. The most affordable company, The Analog Cutting Machinery,Inc. (ACM), charges money according to the length of the stick being cut. Their procedure of workrequires that they only make one cut at a time.It is easy to notice that different selections in the order of cutting can led to different prices. Forexample, consider a stick of length 10 meters that has to be cut at 2, 4 and 7 meters from one end.

Another choice could be cutting at 4, then at 2, then at 7. This would lead to a price of 10 + 4 + 6 =20, which is a better price.

Your boss trusts your computer abilities to nd out the minimum cost for cutting a given stick.

Input
The input will consist of several input cases. The rst line of each test case will contain a positive number l that represents the length of the stick to be cut. You can assume l < 1000. The next line will contain the number n(n<50) of cuts to be made.
The next line consists of n positive numbers ci (0 < ci < l) representing the places where the cuts have to be done, given in strictly increasing order.
An input case with l = 0 will represent the end of the input.
Output
You have to print the cost of the optimal solution of the cutting problem, that is the minimum cost of
cutting the given stick. Format the output as shown below.

SampleInput
100
3
25 50 75
10
4
4 5 7 8
0

SampleOutput
The minimum cutting is 200.
The minimum cutting is 22.

题意

有一个长为L的棍子,还有n个切割点的位置(按从小到大排列)。你的任务是在这些切割点的位置处把棍子切成n+1部分,使得总切割的费用最少。每次切割的费用等于被切割的木棍长度。例如:L = 10,切割点为2,4,7.如果按照2,4,7来切的话,费用为10+8+6 = 24。

分析

设切割小木棍i~j的最优费用为d(i,j),则d(i,j) = min(d(i,k)+d(k,j)+a[j]-a[i]);
就是求d(0,n+1)即可。边界条件为:if(i >= j -1) d(i,j) = 0;
用记忆化更易实现。
AC代码:

#include <map>
#include <set>
#include <list>
#include <cmath>
#include <ctime>
#include <deque>
#include <queue>
#include <stack>
#include <string>
#include <bitset>
#include <cstdio>
#include <limits>
#include <vector>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <fstream>
#include <numeric>
#include <sstream>
#include <iostream>
#include <algorithm>
#define MEM(a,x) memset(a,x,sizeof(a))
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
const int INF = 100000000;
int dp[55][55], a[55];
int d(int l, int r)
{
    int& ret = dp[l][r];
    if(ret != -1) return ret;
    if(l >= r -1) return ret = 0;
    ret = INF;
    for(int i = l+1; i < r; i++)
    {
        ret = min(ret, d(l, i)+d(i, r)+ a[r] - a[l]);
    }
    return ret;
}
int main()
{
    freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int l;
    while(cin >> l && l)
    {
        int n;
        cin >> n;
        for(int i = 1; i <= n; i++)
            cin >> a[i];
        a[0] = 0;
        a[n+1] = l;
        MEM(dp, -1);
        printf("The minimum cutting is %d.\n", d(0,n+1));
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章